Jump to content


ScrollSmoother 'speed' option bug in GSAP 3.11.4

Go to solution Solved by plusex,

Recommended Posts

I mentioned this in another 'resolved' thread but i thought its another issue that deserves its own thread so here it is.


Using ScrollSmoother, if the new speed option introduced in 3.11.4 is set to a value other than 1  ,
if you pause the smoother instance with this.scroller.pause this.smoother.paused(true), and then unpause it with this.smoother.paused(false) and scroll, the page jumps back / upwards.


I saw an unreleased 3.11.5 version was shared in another thread. Wanted to try that, but im using npm and was wondering how i can fix this bug.


Replicated the issue here on this pen:





See the Pen PoBxWrL by farisk (@farisk) on CodePen

Link to comment
Share on other sites

Thanks for reporting that, @plusex. It should be resolved in the next release which you can preview at https://assets.codepen.io/16327/ScrollSmoother.min.js (you'll need to clear your cache, and obviously that'll only work on whitelisted domains like CodePen). 


I'll send you a direct message about how to get the npm files. 

Link to comment
Share on other sites

Thank you . I used the npm package of 3.11.5 and while that solved the initial issue, it seems to have caused / uncovered another bug.

When i pause the smoothscrolling instance, and open a overlay modal, it works fine as i scroll inside the modal.
but while keeping the modal  open and if i scroll outside of the modal (on the main page behind), you can see the page suddenly jump to the end of the scroll.  (i know its the end of the scroll because if i close the modal, i can see the scroll bar at the end of the page and scroll up works as before)

i cant replicate this error on codepen because of what seems like version conflict issues with the other plugins after replacing with your updated version (it already broke the original pen i added in the first post). but i captured a video on my actual code:


Link to comment
Share on other sites

I think that's fixed in the latest beta. Please confirm (you'll need to clear your cache of course). 

Link to comment
Share on other sites

Latest beta meaning the npm package zip file that you sent me yesterday? Or is there a newer version beta version.


Because the issue in the video is captured with the 3.11.5 you sent via dm yesterday.


Link to comment
Share on other sites

Newer as of this evening (when I last posted here) :)

Link to comment
Share on other sites

  • Solution

Just updated the beta package. Yes its fixed. Thank you!


  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.