Jump to content


GSAP Shockingly Green install on Netlify

Moderator Tag
Go to solution Solved by sawyerclick,

Recommended Posts

I can't seem to figure out how to install GSAP's private modules on Netlify. I've followed the CI instructions as given in the dashboard and on Netlify's site. I want to avoid using the .tgz file as this is a public repository.


I encounter the 403 Forbidden - GET https://npm.greensock.com/@gsap%2fshockingly - bad authorization header. Please login again  error every time I try to install locally or when I push code to Netlify. My .npmrc file is as written, with an accompanying local .env file and a environment variable set-up on Netlify:


Link to comment
Share on other sites

  • Solution

Of course I have answered my own question. I added GSAP=xxxxto my machine's .zshrc file, restarted the shell, and it all worked fine. It also seemed to fix my error on Netlify, though I'm not sure how that was the solve.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.