Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
hareeshch

Issue with nmatrix3d

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

hi,

 

Can i scale  object with transform 2d method.When tries with "scale" parameter it uses matrix 3d.My codes have problem with matrix3d .please help me on this.

Link to comment
Share on other sites

Sure, that's actually a performance optimization that GSAP does automatically, but you can definitely prevent it by setting force3D:false. If you want affect the default setting for ALL tweens, you can do:

CSSPlugin.defaultForce3D = false;

Just keep in mind that if you do that, your animating elements won't get layerized for the GPU.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×