Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

Search the Community

Showing results for tags 'f4v'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GreenSock Forums
    • GSAP
    • Banner Animation
    • Jobs & Freelance
  • Flash / ActionScript Archive
    • GSAP (Flash)
    • Loading (Flash)
    • TransformManager (Flash)

Product Groups

  • Club GreenSock
  • TransformManager
  • Supercharge

Categories

  • FAQ Landing Page

Categories

  • Examples
  • Showcase

Categories

  • Products
  • Plugins

Categories

  • Learning Center
  • Blog

Categories

  • ScrollTrigger Demos

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Personal Website


Twitter


CodePen


Company Website


Location


Interests

Found 2 results

  1. Hi all! First off thanks for everything...! So... I have created a "Player" class which extends MovieClip and contains an array of F4V files being loaded via LoaderMax.parse ... In my Main Document Class (Main) I want to transform properties of the entire Player class (alpha, scale, etc.) however the F4V does not see the transformations....It seems I have to reference the content directly within the Main class. For example, if i simply try to set player.visible=false, after i've already added video content to the stage, It does not stick, but if I reference player.video.content.visible=false, it works... What I'm really trying to do is fade the player object out before I navigate back to a main navigation screen. I can fade each video.content individually but I'd rather just write one tween that effects the whole class. Am I missing something simple or is this larger than I think? ...additionally, these transformations DO work with NetStream driving the f4vs. But looping w netStream is ugly , as we know. Thanks!
  2. Hi All I am having an issue with a app that loads video from the app document directory. Its working great with flv format videos. It loads and plays fine. When I try to load mp4 or f4v it appears and acts as though it has loaded. My scrubber moves, time counts down but there is no audio or video. The video is just black. I am using gpu acceleration but have tried with it off and same result. Any help would be great. This is running on an ipad. I have the same app running on an adroid working fine. _videoProperties = new VideoLoaderVars(); _videoProperties.width(747); _videoProperties.height(419); //_videoProperties.bgColor(0x000000); _videoProperties.autoPlay(autoPlay); _videoProperties.container(_container); _videoLoader = new VideoLoader("file:////var/mobile/Applications/F601234555A-D27F-48D5-A484-675F7E84839F/Documents/myvideo.mp4", _videoProperties); _videoLoader.addEventListener(LoaderEvent.COMPLETE, _onLoadComplete, false, 0, true); _videoLoader.addEventListener(LoaderEvent.ERROR, _onLoadError, false, 0, true); _videoLoader.netStream _videoLoader.load(true); private function _onLoadComplete(e:Event):void{ _videoLoader.addEventListener(VideoLoader.PLAY_PROGRESS, updatePlayProgress); _videoLoader.addEventListener(VideoLoader.VIDEO_COMPLETE, VideoComplete); _videoScrubber.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownScrubber); _videoScrubber.addEventListener(MouseEvent.MOUSE_UP, mouseUpScrubber); _videoScrubber.addEventListener(MouseEvent.MOUSE_OUT, mouseUpScrubber); _playButton.addEventListener(MouseEvent.MOUSE_DOWN, playClick); _pauseButton.addEventListener(MouseEvent.MOUSE_DOWN, pauseClick); _muteButton.addEventListener(MouseEvent.MOUSE_DOWN, muteClick); _soundButton.addEventListener(MouseEvent.MOUSE_DOWN, soundClick); _volumeScrubber.addEventListener(MouseEvent.MOUSE_DOWN, volumeClick); _volumeScrubber.mouseChildren = false; _videoScrubber.mouseChildren = false; }
×