Jump to content
GreenSock

Christian_LNET

Members
  • Posts

    5
  • Joined

  • Last visited

Everything posted by Christian_LNET

  1. Thanks @akapowl! That's pretty much it! I'll try going from center to right side of the screen, but this is nearly perfect!
  2. Hey there again! Thanks to your examples I was able to improve my script and made a huge step now The objects get triggered on entering the viewport. Just one last thing that I'm currently not getting right: I'm using xPercent to move the objects but it seems that their reference is not their parent container. This makes the objects move more the further they are to the right. I'm not sure, how to solve this the best way … do I need to calculate something or am I missing some useful parameter? https://codepen.io/cleuenberg/pen/qBrOVjx
  3. Thanks so much to all of you! I'm trying to dig deeper into this with your examples and hopefully will get this running soon
  4. Thanks Cassie for your feedback!! You're right, start and end triggers seem not to be correct. After removing them, the objects in the 2nd scene move a little bit but all others still doing nothing. I have the feeling that all objects get triggered at once, that's why only the first ones are moving. I need to trigger those when their container / scene is entering the viewport. I am wondering, how this could be achieved … any ideas? 🤔
  5. Dear GreenSock community! I am currently working on a project with a horizontal parallax. Each "scene" needs to be in full width and height of the viewpoint with a static background and up to 3 "objects" within this "scene" that just slightly move horizontal with different speed on scrolling, so that it creates kind of a depth effect. I already built this by using rellax library and it worked pretty well, at least while using a modern mouse (Magic Mouse etc) without a physical wheel. My client is using a mouse with a wheel and this is causing the scrolling to be very faltering. I tried to combine my first attempt with several scroll smoothing libraries, nothing worked. So now I completely rebuilt this by using GSAP and ScrollTrigger. In general, the scroll smoothing works now with all kinds of mouses, which is great! BUT: I can only get the objects in the very first scene to move. In all other scenes, the objects do not move. I spent hours on this but can't get it run properly. I really hope to get some feedback on this issue from the community. Thank you in advance!
×