Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

eezz

Members
  • Posts

    5
  • Joined

  • Last visited

eezz's Achievements

0

Reputation

  1. @OSUblake & @ZachSaucier everything works fine on both browsers. 2 different timelines, a setTimeout() with a function including the linked page and a seek(0) for one of the timelines did the job. cheers!
  2. thanks, i'm gonna check those links and see where it brings me
  3. ofc, you can see a demo on https://www.frederik-de-wilde.com/new/ i'm testing with FF 77.0.1 and Safari 11.1.2 - maybe Safari is too old, but still
  4. hello zach, yes, Safari doesn't fire the event, Firefox does it and the intro animation works like it should be. @OSUblake the problem is situated as follows. i have a homepage with a stagger-animation of 3 sections, if you click one section i redirect to another page, until here everything is fine, but when you hit the browser back button Safari gives me an empty page since the animations where triggered and maybe cached or something, the same goes for FF. if i code the unload-snippet into it it goes well for FF but not for Safari. if you have a better solutions, please share thx
  5. hi rodrigo, the "unload"-snippet works fine on modern browsers (ff 77) but doesn't work on Safari 11.1.2. maybe it's the same with flash, back in the days, where the browser back button wouldn't work for several years until the deeplink feature (js) came around. i'm wondering why gsap 3.0 didn't provide a good fix for this... any chance you have an another solution? thanks!
×