Jump to content
GreenSock

pault

Members
  • Posts

    11
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

pault's Achievements

0

Reputation

  1. Absolutely, this is exactly what I am looking for. Thanks Carl, and also thanks for this incredibly quick reply!
  2. I was wondering if there would be a way to parse the css properties of an element. With TweenLite.set() we can set for example a new x value. It would be great if we could somehow read that value back again without parsing the matrix manually and doing this in a different way for IE8<. So when we first do TweenLite.set($myElement, {css:{x:100}}); It would be great if we then could do: TweenLite.get($myElement,"x"), which would then return 100 again. I found myself in the need for this already a couple of times, but haven't been able to find an easy solution for this. Is there anything like this available that I have overseen? If not, then I think this would be a great addition to the API.
  3. Hi Jack, Thanks for your quick reply! I am indeed loading the CSSPlugin (as well as the easepack) What I did not mention in my first post is that it was not happening in Firefox but it was happening in Chrome (did not test other browsers so far). I've just tried to create an isolated version to demonstrate the problem. I was already afraid that it was not that easy to demonstrate, as obviously, else you would have noticed it yourself. What I've noticed is that when I store a reference of the tween and log its properties is that _startTime is always 0 when the tween does not start. Does that make any sense? This got me thinking and lead me to the requestAnimationFrame polyfill by Paul Irish that I'm using (http://paulirish.com/2011/requestanimationframe-for-smart-animating/) So I disabled my code that was using this polyfill and it all worked fine. While writing the above down I had another look at my code and noticed the problem. I was incorrectly calling cancelAnimationFrame(0), while animationFrameID 0 probably being an ID that is used internally by TweenLite. After correcting this mistake, everything seems to be working as expected! It doesn't clarify to me why using TweenMax did solve it, but apparently that is using a different animationFrameID. So long story short. My bad for canceling the animationFrame. Anyway, thank you so much for being helpful and for your wonderful library. Except for this little problem I was having today, it makes my work so much easier and it allows me to create very visually rich applications in a super easy way. Thank you so much!
  4. Ok, so I just checked the versions of TweenLite and TweenMax. I though I had the latest versions, but it seems you've been working hard on the project and I was already quite a bit out of date. I ran TweenLite 1.27. At first I thought this fixed the issue. but apparently it does not. It seems to be related to wether or not I load TweenMax.js. When TweenMax.js is loaded, TweenLite also works fine.
  5. Hi, I just ran into a strange problem. Somehow a very simple alpha tween doesn't start 50% of the time. To make sure I was doing everything correctly I checked wether or not had the correct reference to the object, which seems to be the case. I can manually set the opacity of the element on my page without any problems. I also verified wether or not TweenLite was available at all, but it is and nothing seems to be wrong here. My code gets executed once the document is ready, which rules possible issues due to that out as well. While testing I also added an onStart and onComplete callback with a console.log. Both did not get triggered when my animation did not start. There is also no other place in my application that is controlling the same component. So far it could somehow still be an error in my code, but the fact that after switching to TweenMax the problem doesn't occur anymore, makes me think the problem resides in the library. Does anyone encountered this issue as well? And is there a way to work around it, besides using TweenMax? The tween that doesn't work is: TweenLite.to(this.$el, 1, {css:{autoAlpha:0}}); and the one that does work is: TweenMax.to(this.$el, 1, {css:{autoAlpha:0}}); Nothing special here, except maybe for autoAlpha. I also tried changing that to alpha, but the problem was still there. Thanks in advance, Paul
  6. In case your're loading images from a webserver and want to prevent images from being chached you can always set the noCache property to true. This could rule out that it is a caching issue or not.
  7. You are absolutely right. off course the loaders can not be really paused, they can only be disposed. So yes, I would go ahead and at least not prioritize the loaders of which I know the can not load. Thanks for your feedback!
  8. I'm here again with possibly an other issue I came across. I've got a loader with multiple video sub loaders. Some loaders load non existing URL's, or empty string urls. _loader.append(new VideoLoader("path/to/file.f4v")) _loader.append(new VideoLoader("")) _loader.append(new VideoLoader("")) _loader.append(new VideoLoader("path/to/another/file.f4v")) All video's are part of a sequence, so I first play the first defined video loader, then the empty one, etc... In case the loader has a failed status, I'll continue playing the next url. In case I need to play a given URL, I'll prioritize the loader. In case we come across the empty url's I get a trace message: This is as expected. Now here's what happens. When I monitor the progress of "path/to/another/file.f4v" i notice that it is increasing, but sometimes will be set back to 0. It looks like this happens only after multiple non existing URL's are played. So far in my case it is only playing empty string urls. So what I can do in my case as a workaround is not getting the loader and prioritize it at all when I want to play an empty string file. Then the progress of currently loading files will not be reset.
  9. Hi Jack, That's awesome. Thanks for the very quick fix man! I've got it all running as expected now overhere! I'm not a club GreenSock member yet, but I'll beter become it soon. Thanks again, Paul
  10. Additionally, I'd like to mention hat when I create a new loader and pause it right from the start, then the loader will be paused as expected (simplified, non actual code): videoLoader = new VideoLoader("path/to/file.f4v", {paused:true} loader.append(videoLoader); loader.load(); Setting videoLoader.paused to true or false after it has been instantiated will always result in not pausing the loader at all.
  11. Hi there, First of all I'd like to express my appreciation for both loadermax as tweenmax. They are both incredibly great and makes my life so much easier! So now to the issue I'm experiencing. For an application I'm developing I need to load videos. These video's are loaded in the order in which they are probably needed. They are all subloaders of one main loader. So here's the case. When the user skips a couple of videos, I don't want them to be preloaded anymore (for now), so I thought the best way to proceed was calling the pause() method or setting the .paused property to true for a given loader. After setting loader.paused = true and then tracing loader.paused again, it returns false. Either I am missing something, or this is a bug in loadermax. Hopefully someone is able to help on this. Thanks in advance, Paul
×