Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

amitkhanna

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Newbie

About amitkhanna

  • Rank
    Member
  1. Hey Fredy, I tried your method and it works great but just wondering, whether checking progress over and again causes any overheads? or it it ok...? Cheers, ak
  2. Hi there, I am still unable to successfully apply smoothing to videos when they are running in a browser. My swf file and videos are on the same server. Videos directory is just beside the swf file. I don't have an crossdomain file but I believe we need it if the videos are on a separate server... Any more thoughts? And btw, I love the amount of control and ease LoaderMax provides Cheers, ak
  3. Hi There, Thanks for a quick response. I am going to check what you suggested but this is what my file structure looks like: filename.swf videos/video1.flv videos/video2.flv in flash iam loading videos through a queue queue_1 = new LoaderMax( new LoaderMaxVars() .name("firstQueue") .maxConnections(6) .onComplete(_queue2CompleteHandler) .onProgress(_queue2ProgressHandler) ); // FIRST SET OF VIDEOS queue_1.append( new VideoLoader("video1.flv", {name:"intro", estimatedB
  4. Hi Guys, I am loading a few flv's using VideoLoader and LoaderMax queue. My video is 720x406 and I am stretching it to fit in 1000x564. VideoLoader's API says that smooting on videos is turned on by default and I have tried setting it to true as well. Problem is that when I test the sfw in flash, smoothing works but when I run this file in browser or on it own, no smoothing is applied. I have also tried this: intro.rawContent.smoothing = true; Appreciate if anyone can point out what might be happening. Thanks, ak
  5. Hey there, I have posted this in my other thread also but though of making it a separate topic as it will be easy to search for all viewtopic.php?f=6&t=3765&p=15454#p15454 Hope you are doing great. I had SelfLoader & all my assets on frame 1 in a fla file and when I shifted my flash assets on frame 2 and defined SelfLoader on frame 1, it started working fine. This time I have an AS3 project where my fla file doesnt have anything except for a document class. Now if I specify SelfLoader in my Document class, it doesnt show correct progress, jumps straight to 1.. C
  6. Hey there, Hope you are doing great. Have been using LoaderMax now and really like its simplicity. I have a similar question as last time(in above posts). Last time I had all the code on a frame in a fla file and when I shifted my flash assets on frame 2 and defined SelfLoader on frame 1, it started working fine. This time I have an action script project where my fla file doesnt have anything except for a document class. Now if I specify SelfLoader in my Document class, it doesnt show correct progress, jumps straight to 1 i guess.. Can you please guide me on how to correctly use
  7. Hey, Thanks a lot for looking into the problem and for the tips I'll have a look at the file you have attached... I am using the queue as I plan to load various other swfs later during the project. Regarding the 70% problem, i typed incorrect estimatedSize which I checked later using the target.bytesLoaded and filled in the retrieved bytes, then loader went till 100%. Thanks a lot again for creating & updating your libraries... ak
  8. Here is a simple example. Have a look at the file, if I place the "container_mc" on frame 2 and have an empty frame on frame 1, I start getting the progress updates. But then i dont have any reference to the "container_mc" on frame 1. Am i missing anything? Thanks, akselfLoaderTest.zip
  9. Ok I tried putting all images on frame 1 where all my loader code also exists, but still the same.. no progress update. But if I put all these images in an external swf and load that with SWFLoader things work ok. I noticed one thing here that my loaded swf is displayed at 70% itself and the progress bar doesnt reach the 100% mark. Cheers, ak
  10. Hi there, I recently found LoaderMax and was just wondering why did I never looked at it while all time I was using TweenMax TweenMax is the coolest Ok the thing is, I have a simple swf with 3-4 images in a mc in it on frame 10.. this sizes upto 350kb. Now i want to show a preloader/progress bar as soon as this swf loads Problem is that the progress is never updated and thus progress bars(any kind, component, scaleX etc..) doesnt work. Rather in the end trace shows progress: 1 LoaderMax 'mainQueue' complete I have the following code taken from the docs on frame 1... I am gu
×