Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

roelbeckers

Members
  • Posts

    7
  • Joined

  • Last visited

roelbeckers's Achievements

0

Reputation

  1. Dear Gurus, Here's the situation; I have a LoaderMax, with 4 SFWLoaders. Each SWFLoader has its own LoaderMax to which several ImageLoaders are appended. The progress of the loading is visualised using a simple progress bar. Now this progress bar is jumping backwards now and then. I already read the Tips & Tricks page on LoaderMax and am using rawProgress instead of progress, all LoaderMax in the SWFs have the attribute requireWithRoot: this.root, and I've also appended new SelfLoader(this) to the LoaderMax in the SWFs. In the BandwithProfiler I see that first my SWFs are loaded, and then the Images start loading. Knowing this it's perfectly normal that my progress bar is jumping backwards, because new info concerning the size of the images is only known after loading the SWFs. But is there a way to solve this, so that the info of the total load of the LoaderMax in the SWFs is already know upfront? It's not possible for me to use estimatedBytes, because the SWFs are dynamically loaded from a framework, so the filesize differs. Any tips are highly appreciated! TIA, R.
  2. Tnx for the reply! First thing tomorrow-morning is to take care of the LiquidStage-approach... Cheers, R.
  3. Hi guru's, A problem I'm coping with for some days, so I'd like to tap into your knowledge. Here's the situation; I have a SWF (let's call it the parent) which contains several objects. One of these objects is a LiquidArea, which resizes to the size of the screen to have a fullscreen-effect. The scalemode of this LiquidArea is PROPORTIONAL_INSIDE. Within this LiquidArea I load another SWF (the child). This child-swf has an object which I want to position to the right-border of the screen at any time. Because the LiquidArea of the parent is set to PROPORTIONAL_INSIDE, the child has some blank space at the left and right of it. So this means, that the object of my child that I want to position to the right-border, actually needs to move / over the total width of the child. Is there a way of doing this using my parent/child-setup I've just described? And do you think this is good/best practice? An alternative I was thinking about, is to create a LiquidStage in my parent and move the object to position from the child into a seperate SWF and load this SWF into the LiquidStage of the parent. Using eventHandlers, the object can communicate with the child and vice versa. Still clear? What do you think? Any help/feedback is highly appreciated! Best regards, Roel
  4. Dear GreenSock, Just to let you know that you're components are awesome and that I'm using them all the time in my work. They are a great help... Some sites using your components: - Hotel Basisl (Bed & Breakfast) http://www.hotelbasil.be - JBC (Fashion store in Belgium) http://www.jbc.be --> new site will be online as of August, 16th 2010 Thanks a lot! Keep up the great work... Roel
  5. GreenSock, Thanks again for taking the time to reply. I was pretty sure the problem was somewhere related to me and not to the AutoFitArea functionality ) Your comments and the LiquidStage documentation (which I can play with now as we became Club member - woehoe!) gave me the correct insights and I found my error. It's fixed now... Thanks and cheers, R.
  6. GreenSock, Thanks for your reply. The files are ready for download at https://www.yousendit.com/download/K0JR ... ME5jR0E9PQ. It all starts at inprocess > framework.fla. When clicking the menu-item 'internal' of the left-hand menu, the file inprocess > pages > test.fla will load and this is the file where I have the issue with. Thanks in advance for your help! Cheers, Roel
  7. Dear GreenSock and forum-members, I'm building a site using the AutoFitArea feature of GreenSock. Let me quickly explain the setting. I have an swf with the menu's - let's call this one the framework.swf. In this swf I a movieclip which will contain the content to be shown on childIndex(0) and a movieclip with two menu's (one left, one right) at childIndex(1). Clicking an item from the menu's needs to change the content of the lower movieclip (sounds logical ). So, when a menu-item is clicked, an external swf - let's call this one content.swf - is loaded into the framework content movieclip. This content movieclip in the framework.swf is attached to an AutoFitArea which has the same dimensions as the stage. The content.swf has two custom made movieclips in the library which are exported for AS; one with the background and one with the content. Within content.swf I add both custom made movielcips with addChild. Also in this swf I create another AutoFitArea for the content. The result is that the background is perfectly adapting itself with PROPORTIONAL_OUTSIDE whenever the screen is resized. This works perfectly. The problem is the content movievlip in content.swf. The dimensions set during init are 720x550, and when attached the movieclip I specify that the minimum size is 720x550 and no limitations for maximum size. 720 is the widht of my stage minus the width of both menus. Align mode is set two times to CENTER, and during init of the AutoFitArea I set x to stageWidth / 2 and y to stageHeight / 2. When running the framework.swf and clicking the menu-item, content.swf is shown with a perfect working background, but the content itself is always messing up. The x and y values are not always correct with the result the movieclip is never centered in my stage and background. The size of the content is smaller than specified (i.e.: 550x410) while the movieclip has exact the same aspect ratio. When running content.swf stand-alone it works fine, so I think maybe there's a conflict as I have a AutoFitArea in framework.swf and content.swf. I've been playing with this already all day, without much positive results, so any tips/help are highly appreciated! Hoping for some inspiring tips Thanks in advance... Cheers, Roel
×