Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

Dez

Members
  • Content Count

    24
  • Joined

  • Last visited

Everything posted by Dez

  1. Dez

    Loco Automation

    Hi Mikel It's a little nearer. https://codepen.io/den_smith/pen/VwKvXYz It's taken longer than it should have because of Computer problems. I've had to do another image restore. Along with all the updates etc. Regards Dez
  2. Dez

    Loco Automation

    Okay I can see what you mean now mikel I'm pretty sure I tried a straight version last week, but I'll have another go to make sure. Dez
  3. Dez

    Loco Automation

    Hi mikel, It may be me, but I can't find the images you mention. Did you attach them? Stay cool, Dez
  4. Dez

    Loco Automation

    Hi Mikel, It's really good that you're showing a big interest in my project. I too have had it working with just lines, but when I added the Link as a png or as a svg the problem returns. I'm trying really hard to turn up the stream but I seem to be running out of it. Must be a leaky boiler. Good luck tonight. Dez
  5. Dez

    Loco Automation

    Hi all, I didn't have this problem when I created my other loco a few months ago. See https://codepen.io/spring99/pen/KKpGoyP But the same principle doesn't seem to work correctly this time.
  6. Dez

    Loco Automation

    Thanks akapowl for your valued observation. It seems I need to brush up on my path creation. Also thanks to mikel for your welcome and your reminder from your codepen. In my updated model I've corrected the path which rectified the rotation, as akapowl noted, now you’ll see my problem is still with the right hand end of the link. I can’t seem to anchor it to the movement of the piston. https://codepen.io/spring99/pen/ZEpYjyK
  7. Dez

    Loco Automation

    Hi all, Back again, with more loco automation problems. I thought, after all the brilliant assistance I had last time I posted, I would have no problem creating this animation. How wrong I was. Any help would be appreciated. I think my problems are obvious. Thanks you
  8. Dez

    MotionPathPlugin

    That's exactly what I wanted Blake. I tried the method Zach suggested of Mikels. But both Mikel and I had difficulty keeping the piston end of the rod still. It tended to wander up and down, albeit a small amount. But this way it stays rock steady. Great stuff Blake. I don't know how you do it in such a short space of time. I've been at it for days to no avail, although as Zach says I was using the complete wrong approach. Thanks again to all for your kind help.
  9. Dez

    MotionPathPlugin

    Hi All, Back again with my latest problem. I've been attempting to modify Zach and Blakes "convertCoordinates" pens, to suit my loco animation, but I can't get the piston link arm to follow the blueArm. Any ideas would be greatly appreciated. https://codepen.io/spring99/pen/bGdJMPO
  10. Dez

    MotionPathPlugin

    Hi Mikel, Thank you for taking an interest in my post. I too am of the age when there were only steam locomotives. I remember them well. We’re booked on the newly built “Tornado” locomotive in a couple of months time. Your “work in progress” is brilliant and I’m hoping that mine will be as good eventually. But it’s proving a small headache at the moment. I think my age is getting in the way. Anyway happy steaming to you too, Dez
  11. Dez

    MotionPathPlugin

    Good afternoon guys, Sorry, to have to come back with my latest problem. In the Firefox console I get errors: "Unexpected value undefined parsing cx attribute." "Unexpected value undefined parsing cy attribute." In JS lines 33 & 34. These errors are what seems to be stopping the wheelPath rotation. These errors don't show in my CodePen demo console. But the result is the same. Please see: https://codepen.io/spring99/pen/dyoJRKv Any ideas anyone. I've redone so many times, over and over, with the same result. Thank you,
  12. Dez

    MotionPathPlugin

    Thanks for the replies guys, Acting on your advice I took a closer look at Illustrator via a Youtube video called “How to Optimize/Simplify Path in Adobe Illustrator Tips for Beginners” and discovered the “Object/Path/Simplify” menu. That along with SVGOMG should cut down on my SVG code and make life a lot easier. I'll also be looking at the links Shrug has pointed me to. Regards, Dez
  13. Dez

    MotionPathPlugin

    Hi Zach and Blake, that’s brilliant. I can’t stop looking at it, it’s mesmerising. It’s so smooth and accurate using the new MotionPathPlugin.convertCoordinates() and with Blake's "transform", in the SVG, for the angle. What can I say. Glad I don’t need to do a course in geometry, I’m too old for that. If you don’t mind me asking. What do you use to create the SVG’s? Has anyone ever thought of creating a tutorial for it? I’ve used Illustrator, Gimp, Inkscape, Affinity Photo and Designer etc. But the code I output never looks as concise as yours. Many, ma
  14. Dez

    MotionPathPlugin

    Hi Zack, I hope you’re available to see this post. In reference to you earlier reply to Mikel’s post where you said: “You could do it using some geometry ” Well I could do with a little help with my project because my geometry skills are almost none existing. I’m trying to expand my “Locomotion” animation with a new loco, based on your example, with more moving parts. But the piston and connecting-rod are on a 5.24 degree angle. Which is posing a problem. https://codepen.io/spring99/pen/WNvEdZp Also I could do with the loco travellin
  15. Dez

    MotionPathPlugin

    Thanks once again Zach, you're my Superhero as well as a Greensocks one. Downloading the latest version seems to have cured my problems. I didn't get the email about the latest version update so I was in the dark about that. As for using the old TweenLite API form, I can't answer that one. https://codepen.io/spring99/pen/mdyZLYN I'll attempt to progress on my own now, but I may be back. There's a lot to be learned from mistakes.
  16. Dez

    MotionPathPlugin

    Hi Zach, Sorry if I'm becoming a bit of a nuisance. But I could do with a little more assistance please. My loco animation stops at the start of the second cycle through the background, but the background continues. This is occurring in all the above codepens. Also when I place stop/start buttons on the page and I run my project on my pc, when the stop button is pressed the loco stops but the background jumps and stops at a different position. When I copy my project files into codepen it doesn't replicate the problem for some reason, but the problem changes to somethin
  17. Dez

    MotionPathPlugin

    Thanks Zach. I thought I needed to place it within GSAP to allow me to control what I may require the "background" to do at some future date within the timeline. For example, when I introduce signals, a station, "Stop at next Station buttons" etc., to my project.
  18. Dez

    MotionPathPlugin

    That's brilliant Zach. I can work with that. Earlier you mentioned moving the background CSS to a .set(). How would I do that? Thanks for your input and interest.
  19. Dez

    MotionPathPlugin

    Many thanks Zach for your prompt reply. It’s always the most simple and obvious solutions that are so easily missed. My next objective is to slow down and stop the loco at a station, then leave and speed up again. That’s why I required to have control of the background speed within GSAP. That probably means I have to get my head around Master Timelines. Maybe that will be a future question on the forum. Thanks again
  20. Dez

    MotionPathPlugin

    Hi all, Back again with my up to date Codepen: https://codepen.io/spring99/pen/XWJPZKZ I've got the loco linkage working using the MotionpathPlugin but now I'm having problems with the scenery. It fills the whole page when I run it on my laptop but in my Codepen demo it's failing to work properly by not filling the screen. At the moment it works using CSS @keyframes but, I really want it all working with GSAP. Every way I've tried with GSAP it appears in thin horizontal strips of scenery, repeating 3 or 4 times down the page. Could anyone PLEASE help me on this.
  21. Dez

    MotionPathPlugin

    Many thanks to Mikel and Zach for your wonderful response to my post. It’s more than I could ever have hoped for. It would be great if you combined to build your own loco. I can’t wait to see it. My small project is to attempt to automate a drawing I created many years ago of a “Claud Hamilton” class locomotive, using Serif Drawplus7, (now superseded by Affinity Photo). My inspiration came from “https://codepen.io/devindavid/pen/rxKJLK”. Thank you once again for your amazing help and interest. Regards
  22. Dez

    MotionPathPlugin

    Thanks to Carl I've got a little further in my project of a creating a working locomotive. https://codepen.io/spring99/pen/YzPEgaP Using SVGs was the only way I could think of, to make a simple working example in codepen. My problem now is getting the link-arm and wheel to act as one but they are completely out of sync, without using the small delay on the wheel. I'd like to eliminate that if possible. Plus the link-arm jumps before getting into position. I intend my finished project to have all the wheels and link-arms as separate PNGs. HELP! anyone. Th
  23. Dez

    MotionPathPlugin

    Hi Carl, Thanks for the quick fix. I thought it must be something simple, but I must have missed it in the docs. Thanks again
  24. Dez

    MotionPathPlugin

    Hi, The attached code pen is a very much simplified example of my project. The problem is, my "SUN" slows down, almost stopping after completing each rotation. I can't get it to rotate at the same continuous speed. Also another a minor problem is, after a long while my "SUN" tends to drift off the path towards a 1 o'clock position while still continuing to circle. Any help would be very much appreciated. Thanks
×