Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

philldsx

Members
  • Posts

    2
  • Joined

  • Last visited

philldsx's Achievements

0

Reputation

  1. Hello, I have almost everything working the way I would like but after adding the 4th TransformItem, the TransformManager seems to confuse the selected objects and locks up. Please find the breakdown of the issue below. Any help would be greatly appreciated! COMPONENT: TransformManager AS2 VERSION: Paid version, 6.02 (downloaded 5/9/2010) STEPS TO REPRODUCE: 1) Start with MoveiClip A on the stage. 2) Create MoveiClip B as a duplicate of A using duplicateMovieClip. 2a) Selection, handles and transform work fine. 3) Create MoveiClip C as a duplicate of A using duplicateMovieClip. 3a) Selection, handles and transform work fine. 3) Create MoveiClip D as a duplicate of A using duplicateMovieClip. 3a) Selection, handles and transform work fine. 4) Create MoveiClip E as a duplicate of A using duplicateMovieClip. 4a) Problem starts here... 4a1) The hand mouse pointer appears on mouse-over of the new clip E but when I click to select, the handles appear for the previously loaded object (D) while the 4-arrow pointer seems to recognize the new object (E). 4a2) The TransformManager appears is locked. I cannot move, resize, etc. 4a3) When mousing over the new object, the mouse pointer is "sticky". I'm able to move the mouse pointer out of the transform area if I move quickly but otherwise the pointer sticks in place. It's as if there may be logic that is looping within the TransforManager code that is preventing it from processing other tasks. TRANSFORM MANAGER DECLARATION IN _ROOT: var manager:TransformManager = new TransformManager({allowDelete:true, constrainScale:true, forceSelectionToFront:false, autoDeslect:true, arrowKeysMove:true}); CODE USED TO ADD TRANSFORM ITEM: manager.addItem(eval("main1.submain1." + new_clip_name), TransformManager.SCALE_WIDTH_AND_HEIGHT); NOTES: - I verified the parents of the objects (A through E) are the same. - I have commented out the addEventListener for SELECT and DELETE that we had in there to verify this was not causing it. - The parent clip for A (and B through E) is on a layer that is masked. Thanks, Dan
×