Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

David Knape

Members
  • Posts

    1
  • Joined

  • Last visited

David Knape's Achievements

0

Reputation

  1. This is still a problem if you use the minified GSAP distribution in electron. The solution is NOT to use script tags. The issue is that Electron is also node, and it fakes out the module loader detection code left in these 'minimized' files. To reproduce this error, make an electron app that loads the following two scripts via script tags: https://cdnjs.cloudflare.com/ajax/libs/gsap/1.19.1/TweenLite.min.js https://cdnjs.cloudflare.com/ajax/libs/gsap/1.19.1/plugins/CSSPlugin.min.js Yes, you can modify the files to remove the broken loader code. Another solution is to use the official node distribution. $ npm install gsap In my case, I am writing ES6 with babel and webpack, and the transpiled output is running fine in Electron.
×