Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

gabrielstuff

Members
  • Posts

    5
  • Joined

  • Last visited

gabrielstuff's Achievements

0

Reputation

  1. Hi ! I'm really happy to be able to use tweenmax for animation. I've noticed one issue, that is kind of hard to reproduce. Using chrome and a simple command like : `tl.to(parentClass + ' .card-2', cardAnimInDuration, { scale: 1, left: 0, top: 0, rotation: -5, ease: Expo.easeOut, delay: delayDuration }, 'cardsIn')` produce a nice animation which render perfectly in chrome. In chromium it is also perfect. But in some version of Electron, the content is not visible due to an error in the matrix transform. The produced matrix transform is as follow : chrome 51.0.2704 : `transform: matrix(0.99619, -0.08715, 0.08715, 0.99619, 56.9881, -22.7032);` canay chromium : `transform: matrix(0.99619, -0.08715, 0.08715, 0.99619, 56.9881, -22.7032);` electron 1.2.3 : `transform: matrix(0,99619, 0,08715, 0,99619, 0,08715, 0, 871557);` You'll notice that the "." dots are replaced by commas... and this breaks the transform property. I'll be happy to get some help on this issue. Thanks !
  2. Hi there, I'm playing with the TweenMax API and I encounter some difficulties. I aim to animate a full svg. I use a basic Tween for test puprose TweenMax.to($('#' + 'front_side_down'), 1, { opacity: 1, display: 'inline' }) When the SVG does not contain much nodes, it runs smoothly and nicely. But when I hit more than 1000 groups node of svg path the animation got choppy. I wonder why it influence anything, as in any case we only target one element... Any help would be much appreciate ! Thanks ! P.S : I'm talking about a 3.5mo SVG file
  3. Hey ! thanks for the feedback. I've been reading thru : http://css-tricks.com/tale-of-animation-performance/ and http://www.paulirish.com/2012/why-moving-elements-with-translate-is-better-than-posabs-topleft/ Very interesting ! but i modified the examples given, and if you use larger value for width the choppyness shows up... http://codepen.io/gabrielstuff/pen/wBgmz Kind of weird that such a bug (feature) is present... feel like doing something wrong.
  4. As I was browsing around, I notice one demo where it is evident. The bar here : http://codepen.io/bassta/pen/Fypuw If you click on the menu you can see that the movement is not smooth and got some glitch. An other infos is that CSS animation works perfectly fine.
  5. Hi ! I'm using Chrome Version 31.0.1650.63 on OSX Maverick and I've noticed some jittering/tearing on the basic animation. For a fast animation you can not really notice it, but with middle slow animation such as this ones : http://codepen.io/GreenSock/full/Kajpu it is getting annoying. The issue can simply show with something like : TweenMax.to($el, 10, { x: $(window).width() + $el.width(), onComplete: function() { $el.remove(); } }); I didn't notice it on previous beta version... and I can not say when I see it appearing on the first time. What I can say, is that I see it on Firefox (last version) and Safari (last version) Thanks
×