Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

WKidd

Members
  • Posts

    10
  • Joined

  • Last visited

Everything posted by WKidd

  1. I tried putting that code snippet into an "onLoaderInit" function, and attaching the event like this: mLoader.addEventListener(Event.INIT, onLoaderInit); But the function is never called. I'm guessing that's not what you meant by //run as soon as the Loader's INIT event is dispatched: And that I'm not testing this properly. Let me know what to do so I can test this for you?
  2. Nope, doesn't crash. That one works just fine Does it matter which version I use in my project, out of the test SWFLoader versions that didn't crash?
  3. Certainly! The "with RSL" is the one that works for me Does that help you know what's wrong? Thanks!
  4. I assumed this would work the same on the desktop as well as the device, so I only tried it on the desktop. It was fine, no error or trace statement. I even added an else to that if: if (e.target.content is AVM1Movie) { trace("old swf"); } else { trace("All ok"); } And it prints "All ok". 2. Still crashes. 3. BRILLIANT!!! Perfect, that worked wonderfully! It downloads and plays just fine, now. Thank you so much for all your help; you have my eternal gratitude. You have no idea how happy I am that this is working! Wow, okay, so excited. Can I simply continue using your modified version of SWFLoader, or will that cause problems down the road? Because it's working wonderfully for me right now Thanks again, so very much!!
  5. Yep, the ImageLoader works great (tested it with images from the same place on the server as that samplevid.swf). The Security.allowDomain(FILE_PATH) still crashes the program even on the desktop, so I removed that after putting all your suggestions back in. With all your other suggestions included, though, and with a swf that contained nothing but an image imported to the stage, it still crashed when I loaded it on the device with LoaderMax (and still works fine when I use a regular loader). No, I'm not doing any of those things that you mentioned. I am loading both the swf and an external image. In the complete handler, I have this code: swfIsLoaded = true; myMC = e.target.content as MovieClip; myMC.stop(); addChild(myMC); myMC.scaleX = 2; myMC.scaleY = 2; myMC.x = 55; And then on frame constructed, I check if the swf and image have both downloaded. If so, I call myMC.play(). I do nothing else. 4. No; same result.
  6. Thanks so much for your help; I really, really appreciate it! I love LoaderMax and was using it for images in other projects before now; I would really love to get it working with these remote swfs on iOS. It prints "Desktop", even on the phone, which seems rather odd... Is it supposed to do that? I get this error immediately when the program starts, even running it on the desktop: SecurityError: Error #3207: Application-sandbox content cannot access this feature. at flash.system::Security$/allowDomain() When I run it on the device, the error is the same but the "at" is in a slightly different place: SecurityError: Error #3207: Application-sandbox content cannot access this feature. at LoaderTestClean/startLoad() Am I using this code snippet incorrectly? Before I begin loading the swf, I have Security.allowDomain("http://myServer.com/myFolder/samplevid.swf"); 3. Still crashes. 4. Still crashes. Also I tried ideas 3 and 4 together, just to see what would happen, and it still crashes... Thanks again, so much, for troubleshooting this with me. Would really love to be able to use LoaderMax! It's so much simpler and cleaner that just a bunch of regular loaders.... Thanks!
  7. Hi, Do you have any other thoughts as to why this might be happening? I've kept playing with it and no matter what swf I use, no matter how simple, it works with a simple loader but fails with LoaderMax. Thanks!
  8. 1. I am using the latest version (downloaded again today just to be sure!) 2. Sort of; when I load a different swf I don't get the "Icon" and "FLVPlayback" error messages, but it still crashes (only on the device, not the desktop). It just crashes without any output. 3. No. It still crashes with the same output on the device. 4. When I run that and trace the className, I get: flash.display::MovieClip Something I meant to say earlier... It does actually download the swf, because I get this output: [sWF] /staging/AA/Test/samplevid.swf - 1168992 bytes after decompression But it crashes immediately after that. /confused Thanks!
  9. Hi, thanks for your reply! That's unfortunate to hear, because I'm not using FLVPlayback anywhere in my code and I've never even *heard* of an Icon class. (I tried googling to find out what the Icon class was, but I couldn't find anything.) When I use a simple URLRequest and Loader instead of LoaderMax, everything works just fine; I get no errors and the video plays properly. So when I saw the words turn blue inside the SWFLoader constructor (after trying that on a whim) I thought I'd found the problem as something I was doing wrong with LoaderMax. Thanks for letting me know that the blue keyword doesn't mean it relates to that LoaderMax function. And to answer your question, I am building to AIR 3.2 for iOS. So if it's not a problem with my usage of LoaderMax, I don't know what it is, because like I said before it works fine when I just use the built-in URLRequest and Loader classes. It took me a little while to reply because I was setting up a sample project to share with you. I made a test project and cleaned things up a bit, and also created a sample .swf because the .swf I want to load belongs to a client and I'm not sure if I can share it. Interestingly enough, I don't get quite the same errors with the sample .swf as I do with the one I was loading earlier. It still crashes as soon as the .swf loads, but I don't get the "Icon" and "FLVPlayback" error messages. It simply crashes with no output whatsoever. Sample project is attached. At the start of the LoaderTestClean class, you'll see a variable "USE_LOADERMAX_FOR_SWF". When set to true it uses LoaderMax to download my swf; when set to false it uses a generic loader. When not using LoaderMax, it runs fine both on the desktop and on the iPhone. If you tell it to use LoaderMax and then run it in Debug mode on the desktop you'll see that it works fine; but when you build it on a device with LoaderMax it crashes. Any insight or ideas you have on this matter would be very much appreciated. As you can see, the only difference between the code which crashes and does not crash is that I'm using LoaderMax to download the swf when it crashes. Hopefully you can spot what it is that I'm doing wrong! It won't let me upload the sample with Greensock's libraries included because the zip becomes too large, but if you simply include them inside a "com" folder and then the "greensock" folder, it should all work. Thanks very much for the speedy reply and your assistance, ~WKidd LoaderTestCleanProj.zip
  10. I have an AIR for iOS application where I'm downloading remote swfs and then playing them. When I was using a generic loader this worked exactly as intended, but I wanted to switch to LoaderMax. When I use LoaderMax SWFLoader to download the swfs, it works fine when I test in Debug mode on the desktop. However when I run the app on the iPhone, I get these errors: ReferenceError: Error #1065: Variable Icon is not defined. ReferenceError: Error #1065: Variable FLVPlayback is not defined. I've searched the documentation and code files for SWFLoader and its base classes, but I can't find any reference to these properties. However, when I'm creating a new SWFLoader object and I type "icon" or "FLVPlayback" as properties to pass to the SWFLoader, Flash CS6 turns them blue (implying that they're valid parameters to pass to the constructor). The code that doesn't work on the device: var mySwfLoader:SWFLoader = new SWFLoader(val, {name:key, autoPlay:false, onComplete:completeHandler}); The place where I can see "icon" and "FLVPlayback" turn blue: var mySwfLoader:SWFLoader = new SWFLoader(val, {name:key, autoPlay:false,[b] icon:[someVar], FLVPlayback:[someVar][/b], onComplete:completeHandler}); So what I gathered from this is that, for some reason, when running on iOS the app requires that icon and FLVPlayback are defined. But I can't find any documentation on these properties in the LoaderMax classes themselves or online. Can anyone tell me what default properties I can pass to these, or at least give me some documentation on what data types they are/what they're expecting? (I tried passing 'false' to each, hoping maybe they were booleans, but to no avail). Any assistance whatsoever would be appreciated in this matter. Thanks!
×