Jump to content
GreenSock

ti-sign

Members
  • Posts

    4
  • Joined

  • Last visited

ti-sign's Achievements

  1. Hey @Carl Thanks so much for the input! That looks really nice and I just learned that there is a thing called wrap, amazing 😃 My website always has a burger menu, so it doesn't change hight on resize (and it has no background color, so I need to change the logo to stay visible) I've experimented a bit further myself and here is a solution that seems to work with reading out hsl values: https://codepen.io/tisign/pen/OJEoyVx For anybody seeing this, I take no responsibility regarding efficiency (Not because of GSAP, I just don't know what I'm doing 😆), I myself am gonna use the color version, as I only use three colors on my site. Ouh, and it doesn't work without background color and/or transparent backgrounds.
  2. Hey there This is one part demo and one part question. I've been lurking in the forum for some weeks to get help and hopefully this can help somebody else (and someone may even make this better, probably). I've been looking for a possibility to change my logo in the navbar depending on the color of the section it's on (because I have a transparent navbar). I didn't find a suitable solution so I created one on my own. If this is helpful to anyone with a similar problem, have fun! You could even go further and check for the lightness in a hsl value to cover all colors (or the w and b in hwb). However, here's my question. I have absolutely no idea if this is a performant or nice way to do it (I'm fairly new to JS and very new to GSAP). So if any of you pros out there see an immediate stupidity in my code, feel free to correct me 😄.
  3. Okay, imma hit myself in the head, but I leave this online if anybody else stumbles upon this. Do not load uncompressed images during developement. GSAP doesn't seem to like it if it has to animate 21MB of images all of the sudden.
  4. Hey there, gsap novice here I have a simple fade-in animation on my site. However, the first time the animation loads, the whole site janks and the animation doesn't look good. All subsequent times look extremely smooth. I've tried to recreate it in a codepen, however, there the code seems to work flawlessly. I have no other scrollTrigger or gsap animation on any of the here targeted elements. Did anybody already have that problem and see a solution? Thanks in advance!
×