Jump to content
GreenSock

Anderw

Members
  • Posts

    8
  • Joined

  • Last visited

Everything posted by Anderw

  1. thank you very much craig for your availability, in fact removing jquery also works on worpress, but the animation is not smooth as it should, even reloading and emptying the cache! I also tried with a simple parallax, and the animation is jerky, I can't to understand where the problem is, the console does not give me any errors
  2. Hello everyone I am trying to insert some animations in my custom theme on wordpress, using gsap (which is very much that I wanted to try it)! but the scroll animation doesn't seem to work, I don't understand where the error is, because in the wordpress console it doesn't report anything to me! I think I have correctly inserted the scripts in the function.php, thank you in advance for your help
  3. thank you for your support and your availability
  4. is there any way to find out the order in which the gsap files are loaded? maybe discovering I can find a way to solve this problem! in other projects that I have used swup and locomotives this type of errors never happened to me, it almost seems that there is a conflict of css even if it is not!
  5. I was aware of this but despite putting the correct name the error remains
  6. actually exists as hero block, but it is part of this other code block, sorry but I have several, I give you the complete code of the error warnings https://codepen.io/Andrewwolf/pen/jOZEQqd I am using action-created-blocks which allows me to create reusable code blocks for my works, they are displayed on the page but I don't understand why they don't work as they should
  7. also the following warnings come out in the console, I have consulted and studied practically the whole forum but nothing
  8. Hello everyone I'm new in Gsap. I have integrated into my wordpress theme the related scripts that I needed, but they don't seem to work perfectly, any help would be useful,thank you very much these are the inclusions of the scripts: if ( ! function_exists( 'New_scripts' ) ) { function New_scripts() { wp_enqueue_script( 'New-gsap', get_template_directory_uri() . '/js/gsap.min.js', array( 'jquery' ),null,true ); wp_enqueue_script( 'New-ScrollTrigger', get_template_directory_uri() . '/js/ScrollTrigger.min.js', array( 'jquery' ),null,true ); wp_enqueue_script( 'New-ScrollToPlugin', get_template_directory_uri() . '/js/ScrollToPlugin.min.js', array( 'jquery' ),null,true ); wp_enqueue_script( 'New-CSSRulePlugin', get_template_directory_uri() . '/js/CSSRulePlugin.min.js', array( 'jquery' ),null,true ); wp_enqueue_script( 'New-script', get_template_directory_uri() . '/js/scripts.js', array( 'jquery' ),'', true ); if ( is_singular() && get_option( 'thread_comments' ) ) { wp_enqueue_script( 'comment-reply' ); } } } add_action( 'wp_enqueue_scripts', 'New_scripts' ); I've been trying for days I can't figure it out
×