Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
SBoudrias

Timeline tweenTo ignore pause

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

I like to set pause on my timeline to help debug certain state. `timeline.addPause(1.3)`

 

The issue is when I use `timeline.tweenTo(1.5)`, it skips the pauses.

Link to comment
Share on other sites

Yep, that's expected behavior. Remember, tweenTo() just creates a tween that animates the playhead position (the time() property) of the timeline.

 

You're welcome to pause() that tween if you'd like. 

var tween = timeline.tweenTo(1.5);
//then later...
tween.pause();

Or kill() the tween or whatever. You can also TweenLite.killTweensOf(timeline). Lots of options :)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×