Jump to content


Need KineticPlugin for KineticJS V5.0.0

Moderator Tag

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

The actual KineticPlugin

VERSION: 0.4.1

DATE: 2013-07-10

does not work with the new KineticJS V5.0.0


Simple Tweening of the y positon and opacity of an Kinetic.Line does not work.


tl.to(kcObj, 0.5, {kinetic:{y:10}, ease:Elastic.easeOut});
tl.to(kcObj, 0.5, {kinetic:{opacity: 0}, ease:Power4.easeOut});



Link to comment
Share on other sites

Hi and welcome to the GreenSock forums.


Yeah, it looks like there have been changes to Kinetic getter/setter methods that break the KineticPlugin.


We'll look into this further, but can't do it immediately.


In the meantime I suggest you revert back to Kinetic 4.7.4


We will update this thread after we have assessed the situation.


Thanks for reporting the issue.

Link to comment
Share on other sites

Update: We've reached out to Eric (author of KineticJS) who we have worked with previously.

I'm sure we will get it worked out.


In the meantime, using setX and setOpacity methods with v5.0.0 seems to work


TweenLite.to(redLine, 1, {kinetic:{setX:200}});
TweenLite.to(redLine, 1, {kinetic:{setOpacity:0.2}});



  • Like 1
Link to comment
Share on other sites

It looks like there were significant API changes in KineticJS 5.0.0 which rendered our KineticPlugin non-functional. I've attached an updated version that should now fit with the newer API, although I haven't had a chance to do substantial testing. Would you mind dropping this new version in and letting us know if it works well for you? I included the whole GSAP library, just to make sure you've got the latest files for everything. 


  • Like 2
Link to comment
Share on other sites

Hey, it looks all ok, entire app works without changes to the tweens. Many thanks to you.

  • Like 2
Link to comment
Share on other sites

hi there !

Jack, i tried out the preview package you uploaded for bluetrout but didn't manage to have my app to work.

So the new kinetic plugin (0.5.0) isn't working for me for the moment.

Just to let you know.

I'm still trying to see if the plugin is the problem or if it comes from somewhere else.

I'll let you know if i find something useful.

Link to comment
Share on other sites

Sorry to hear that. Can you please post a very simple codepen or jsfiddle that clearly demonstrates the problem? Carl, me, and Bluetrout tried the new package and it seems to work well with the latest version of KineticJS. Are you sure you updated? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.