Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Polarathene

First load takes 10x the duration?

Recommended Posts

I know that I shouldn't be too concerned as this is something I've noticed while testing my app in debug. When I transition to a screen that has video content I've noticed my ui elements repositioning(Feathers/Starling) and figure it's due to the workload being too much for that frame. Haven't looked at scout but know that not loading video prevented it.

 

I could alternatively load the video when the user presses the play button instead and have any delay occur there instead, what I'm interested in though was that the load time of 0.64 is for the first time I load a video, when I try any other it becomes 0.078, this is irrespective of what video I am loading(<15mb mp4 h264).

 

I've had a look at the api and tried various options but had no luck. Am I right to assume there is some sort of initialization for the loader? It seems to be when I tell my loadermax queue to load the first file. Is there a way that I can avoid this delay by doing something with loadermax during my app startup? Again unlikely a major issue as long as it does not scale with file size in release.

Link to comment
Share on other sites

This doesn't sound like anything caused by VideoLoader or fixable with VideoLoader.

As you mentioned there is a certain amount of processing overhead involved with loading a video and displaying it. Have you tried without VideoLoader? Any noticeable difference?

Link to comment
Share on other sites

  • 2 weeks later...

I'm not sure how I would check the loading time like I do with VideoLoader. Not too concerned, was just curious why the first load takes 10x the duration regardless of the video file, and then any other video's same one or different will load considerably faster. Would seem that it's not related to the video but something on the code end, could be specific to the runtime handling new Video() rather than anything to do with loading.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×