Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
johny

Found workaround for chrome leaving trash on 3d animations

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi,

 

I just encountered a bug in Chrome (possibly other browsers too) leaving 1px trash during 3d animations, like n the attachment.

 

All you need to do is add 1px border, or box-shadow to the animated element. If you don't want it to be seen - in color of background, or transparent:

 

border: 1px solid rgba(0,0,0,0);

border: 1px solid transparent;

 

I hope it'll help someone. :)

 

John.

post-13639-0-52734700-1361710425_thumb.png

  • Like 1
Link to comment
Share on other sites

That "bug" actually has nothing to do with GSAP - it's just a browser thing related to rendering 3D objects (annoying, I know). I've noticed that I can often get rid of it by setting a z-index on the animated element and/or setting its backface-visibility to hidden (or -webkit-backface-visibility in this case).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×