Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Igor

VideoLoader playing

Recommended Posts

Good day!

I have a problem with VideoLoader. Somtetimes video played very fast!

Sometimes good, sometimes fast.

My flv file duration is 2 seconds... very small and i think that is problem.

 

My constructor:

videoLoader = new VideoLoader(filename,
                         {autoPlay:false, container:this,  width:size ? size.x : null, height:size ? size.y : null, repeat: -1, bufferTime:4} );

 

So if set bufferTime to 4 , I have a problem? but if set it to 0.01, its better.. but with new problem:

syncronization of videos not work:

 

 

 



private function onVideoComplete(e:Event):void 
   {
     playComplete = true;

     var synthSymbolsPlayFound:Boolean = false;
     for (var i:int = 0; i < synthSymbols.length; i++) 
     {
       var videoLdr:VideoSprite = synthSymbols[i];
       if (videoLoader.url == videoLdr.videoLoader.url && !videoLdr.playComplete)
       {
         synthSymbolsPlayFound = true;
         break;
       }
     }

     if (synthSymbolsPlayFound)
       videoLoader.pauseVideo();
     else
     {
       for (i = 0; i < synthSymbols.length; i++) 
       {
         if (videoLoader.url == synthSymbols[i].videoLoader.url)
         {
           synthSymbols[i].videoLoader.playVideo();
           synthSymbols[i].playComplete = false;
         }
       }
     }
   }


 

These problems are in the last version VideoLoader. sorry for my bad english

Link to post
Share on other sites

You definitely shouldn't be setting your bufferTime to exceed the duration of the clip. As far as synchronizing, I'm not entirely sure what you mean. Keep in mind that Flash's NetStream (which is what VideoLoader is built on) needs time to connect to the stream, buffer it, and begin playback, so if, for example, you try to start playing 10 NetStreams at exactly the same time, some may take a little longer than others to buffer and begin playback. There are a lot of factors involved, like network traffic, compression, CPU load, etc. Were you saying that synchronization worked in an old version of VideoLoader but broke in a more recent one?

Link to post
Share on other sites

Did you ever resolve this issue?  I'm experiencing the same thing.

Link to post
Share on other sites

I'm not aware of any issues in the latest version of VideoLoader, but I can't speak for Igor about whether or not he resolved his problem. Please make sure you're using the latest update, and if you're still having trouble, post a sample (simplified) FLA that we can publish to clearly see the issue. 

Link to post
Share on other sites
Hi,

 

I've prepared one test regarding "flicking" video. In case I build scene from FLA file - everything is ok, but there are some flicks if I compile it from FlashDevelop. No matter is it in debug or in release modes.

 

It seems this is a problem of SDK, but if I use some previous versions of greensock in FlashDevekop all is ok.

 

I suppose the issue is depends of number of objects in scene.

 

Flashdevelop + SDK 4.6.0

sample:


Best regards

Link to post
Share on other sites

Sorry, but this sounds like a Flashdevelop issue which we can't support. I published from Flash and it worked fine as far as I can tell. :(

Link to post
Share on other sites

Its strange, because the most of programs aren't made in flash ide CS6. But flashDevelop is just simple IDE, which runs the code with SDK. So this problem you'll meet in other IDE such as inellij IDEA, eclipse and even notepad++. Everything will be compiled with official  adobe SDK.

That's why there are two questions:

1. Do you support the official SDK?

2. Do you have an idea why there is a problem with flicking video(maybe old version of SDK, flashplayer, greensock)?

 

Looking forward to you answering!

Best regards

Link to post
Share on other sites

1) Yeah, LoaderMax/VideoLoader is just a layer of AS3 that sits on top of Adobe's own classes (like NetStream, Video, LoaderContext, etc.) and I'm not aware of any incompatibilities. Just because Flashdevelop says they use Adobe's SDK doesn't necessarily mean that the compiler does that all accurately, but I'm really not sure. I do know that Adobe's own NetStream class has quite a few bugs in it (which VideoLoader works around). That's one of the main reasons so many people have used LoaderMax - it implements workarounds so they don't get "bitten" by those bugs/inconsistencies.

 

2) I have no idea why it might be flickering just on the one that's compiled using Flashdevelop and not Flash. Sorry. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×