Jump to content


SWFLoader hangs

Recommended Posts

Hi I'm using SWFLoader to load a SWF into a webpage. Simple stuff and the SWF I've whittled down from 6,100 Kb for 690 kb because I thought that might be the problem.


Long story short through progress loader event and trace I notice the file gets to about 40% and just stops there. When I reload it starts from where it left off and gets to around 80%. A third reload finally completes.


I tried a onFail function and trace but that doesn't seem to be firing off. It just hangs, waiting.


I don't suspect a problem with Loadermax however I'm banging my head trying to figure out where the problem is, and I thought I would just post this in case someone has seen something like this!




Link to comment
Share on other sites

I can't remember ever hearing of something like this so I'm not quite sure what to recommend other than trying to isolate the problem further. For example, try:

  1. See if you can load the problematic swf using a regular Loader (remove LoaderMax from the equation). If it works great, we know there's some conflict with something LoaderMax is doing (I kinda doubt this, but it's possible).
  2. Try a different swf that's a similar size - does it work? If so, try removing pieces of the problematic swf and re-publish and reload and keep doing that until you get it to work. Then you will have identified what portion of the subloading swf is causing the problem.

Link to comment
Share on other sites

Thank you for the reply. The issue was finally resolved a couple of hours ago-- at least for now!


Long story short It definitely was not LoaderMax.


Long story is I contacted the company that hosts the website and they gave me the brush off. They told me it was my program. I believed them and wasted 4 days looking for a bug that didn't exist.


Finally I unearthed a thread describing the same exact problem and ascribing it to GoDaddy servers that begin with 50.63. I checked my server... and it was 50.63.


After an angry phone call where they still denied any problem on their end, my SWF magically loaded. Quite the coincidence!

Link to comment
Share on other sites

Wow, that sounds unbelievably frustrating. Sheesh.


Well, I'm glad it's resolved and I'm even glader (I made that word up) that the problem wasn't LoaderMax-related :)

Link to comment
Share on other sites

  • 6 months later...

Hello there,

I'm actually facing the same issue here... But my application (AIR app) is trying to load a 112KB swf instead. It just freezes the whole application when trying to load the file. In order to make my self clear, I've added the eventListeners (progress and complete) traces so it's easier to understand, this is what I got when loading the SWF file:

progress: 0.32768
progress: 0.574705
[sWF] swf/1x/map_04.swf - 118.084 bytes after decompression.
progress: 1

The app freezes for (almost 0.5 secs) right after the decompression trace.
Any ideas of what could be happening here?

Thank you...

Link to comment
Share on other sites

Hi Stone,


Welcome to the GreenSock forums. Sorry to hear you are having trouble.

My best guess is that there may be a lot of code being processed when the loaded swf is being instantiated, some thing that would cause the processor to hang. I'd suggest a few tests


1) first try loading a smaller, very simple swf (although 112kb certainly isn't inordinately large). Same problem?


2) rip out SWFLoader and use the native AS3 Loader with the problematic swf. Same problem.


This will help us figure out if the problem is inherent to the swf you are loading OR if there might be a problem specific to SWFLoader. 

Link to comment
Share on other sites

Hi Carl,


Well I've tried your tests and, yes it does goes smoother with a 50KB swf, but it's still noticeable, the good news (for you guys) is that trying to load it with the native Loader presents the same behavior.


I've been asking in other forums and I've been told that it's not the loading, it's instiantiating the flash objects from the SWF that freezes the app (because flash it's a single-threated platforms), and that there is no workaround.. :(

Link to comment
Share on other sites

Thanks for the updated info, good to know.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.