Jump to content
GreenSock

vdubplate

How do I turn off easing in a tween

Recommended Posts

I'm trying to make a scrolling text field in a file I'm working on. The problem I am having is that no matter what I do the text eases in and slows down at the end of the tween. I have tried the code below with no luck:

 

TweenLite.to(text1_txt, 30, {x:-2000, y:464, ease:"None"});

 

TweenLite.to(text1_txt, 30, {x:-2000, y:464, ease:"Linear.easeNone"});

 

Can someone explain what I need to do to get a linear tween?

 

Thanks in advance

- John

 

PS:

I would have searche dthe forums for "how to turn off easing in a tweeen" but the forum won't allow me.

Link to comment
Share on other sites

The problem is that you're putting the ease in Quotes, meaning you're treating it as a literal String rather than a reference to an actual easing method (function). Just remove the quotes.

 

TweenLite.to(text1_txt, 30, {x:-2000, y:464, ease:Linear.easeNone});

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×