Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
lucasget2dachopper

Error loading local SWF - Error #2032: Stream Error and Error #2035: URL Not Found

Recommended Posts

I'm getting the following errors below, when I'm loading a SWF into another SWF, the parent will eventually be an executable.

 

I don't think this error is related to LoaderMax (great product by the way), but I feel that since you guys are the experts in loading assets you might know the answer.

 

Things to point out:

 

- when I change the method type to URLRequestMethod.POST it loads great, but for some reason I can't grab the parameters from the loaded SWF. I'm using this.loaderInfo.parameters["appendPath"] but it's undefined, I think that is only for query string variable? If I knew the way to grab the posted values, I think that would fix my problem.

 

- I have queue.append twice only to show the code.. when I run the code I comment one out, one throws URL not found the other is the Stream Error.

 

- I have modified my Flash Professional CS 5.5 so that I can compile Air for IOS, I did read somewhere something about using debug player that may be causing this, I need to test this app on a different Flash professional version that is not modified. I don't remember the exact things I did, but i had to change XML's and update players.. not sure if that is causing this error.

 

- I've also tried passing file path as a string with the query params at the end, the minute it saw a key it thru the error, when I had the ? it loaded ok. It's like the minute it sees a query string it blows up.

 

- The child.swf is compiled using FLASHDEVELOP 4.0 with compiler "C:\flex_sdk_3.3.0.4852"

-use-network=true and "Use Network Services = False" not sure if that is the problem, I do have access to the child and can compile it in anyway needed.

 

- The Parent.swf is compiled in FP CS 5.5 targeting flash player 10 and above.. I've test all players and got the same results.

 

Please help!! thx in advance!

 

var request:URLRequest = new URLRequest("assets/child.swf");
  var data:URLVariables = new URLVariables();
data.appendPath = "test";
request.data = data;
request.method = URLRequestMethod.GET;  
  var queue:LoaderMax = new LoaderMax({name:"mainQueue", onProgress:progressHandler, onComplete:completeHandler, onError:errorHandler});
queue.append( new SWFLoader(request, { name:"loaderClip", auditSize:true, container:container.holder, y:0, x:0 } ) );
queue.append( new SWFLoader(request, { name:"loaderClip", estimatedBytes:369920, container:container.holder, y:0, x:0 } ) );
queue.load();

 

 

progress: 0
LoaderMax 'mainQueue' is complete!
----
Error on SWFLoader 'loaderClip' (assets/child.swf): Error #2035: URL Not Found. URL: file:///C|/CDA/DVD/deploy/assets/child.swf?appendPath=test
----
error occured with SWFLoader 'loaderClip' (assets/child.swf): SWFLoader 'loaderClip' (assets/child.swf) > Error #2035: URL Not Found. URL: file:///C|/CDA/DVD/deploy/assets/child.swf?appendPath=test

----
Error on SWFLoader 'loaderClip' (assets/child.swf): Error #2032: Stream Error. URL: file:///C|/CDA/DVD/deploy/assets/child.swf?appendPath=test
----
error occured with SWFLoader 'loaderClip' (assets/child.swf): SWFLoader 'heaLoader' (assets/child.swf) > Error #2032: Stream Error. URL: file:///C|/CDA/DVD/deploy/assets/child.swf?appendPath=test
progress: 0
LoaderMax 'mainQueue' is complete!

Link to post
Share on other sites

Update: I tested on another machine with FP CS5.5 that was not modified and same error, when I switch to AIR 2.6 from the Publish Settings the code works, any idea?

Link to post
Share on other sites

I'm not sure - maybe newer versions of AIR package your files differently in such a way that the relative paths don't sync up (which has nothing to do with LoaderMax of course). Have you tried messing with the relative paths at all? (like adding "../" before them)

Link to post
Share on other sites

I'm working on this now and I realized once I publish as an executable it works fine.. same code, I also have a feeling that if I place these files on a webserver they will work as well.

 

I found someone having the same problem and they point out that it only happens to them in the FLASH IDE, which is exactly my problem.

 

http://www.kirupa.com/forum/archive/index.php/t-335122.html

 

Does anyone know how to fix? it's so strange and it's driving me crazy because I don't want to create executables everything I want to test??

Link to post
Share on other sites

Hi guys, thanks for taking the time to look at my post, much appreciated... I actually got an idea from another post in this forum. Since I had access to the child SWF, I deceided to dispatch an event from the parent to the child and I pass URLVariables class to the child, worked like a charm.

 

Had to make some modifications to init approach of the child, but it's so much better doing it with event handling!!

 

I did find something about the problem from FP IDE, basically since it's on the file system, it looks at the query string as it physical file name, that's why we get the URL not found error from flash. I hope adobe fixes it, I spent so much time on a simple lillte app.. anyway lesson learned!

 

Thx!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×