Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
TheCosmonaut

Transform Handles Not Disappearing

Recommended Posts

Hi there!

 

I've got an application with multiple transform managers overlapping. Users upload an image into a transform manager and can then resize and reposition the various managers. The managers are not forced to front and I have autoDeselect set to true.

 

Everything is working like a charm. The only strange behavior is that if I resize an element, move it, and then click click anywhere else in the swf, the bounding box does disappear entirely. Sometimes half the box disappears, sometimes the whole box remains. I can't seem to do anything to force the bounding boxes to disappear entirely - I've tried forcibly deselecting the items using Actionscript, I've tried forcibly moving the selection boxes slightly... nothing seems to work.

 

Is this something that anyone has seen before? Any tips on steps I can take to fix it?

 

Thanks in advance,

 

--eric

 

BTW: I'm compiling using CS5 on a Mac, testing using Firefox 4.

Link to comment
Share on other sites

By "bounding box", you don't mean the one that TransformManager creates (with the handles on the corners/edges) right? It sounds like maybe you're talking about the focus rectangle that Flash adds to certain components. There seems to be several techniques necessary based on whether your using Flex or Flash, which type of component you're using, etc. Here are a few, but I'd suggest using Good old Google to do some research of your own.

 

stage.stageFocusRect = false;
focusManager.deactivate();
myComponent.setStyle("focusAlpha", 0);

Link to comment
Share on other sites

Hey there!

 

Unfortunately, I AM talking about the bounding box (with handles) that TransformManager creates. It's a strange bug - I've tested on other platforms (Mac Safari, Mac Chrome) and it only appears to happen on Mac Firefox 4.

 

Have you seen this type of behavior before? I've got three different TransformManagers on my stage - would that potentially be causing the issue?

 

Best,

 

--eric

Link to comment
Share on other sites

Weird. No, I never heard of anything like this. Could you send me a sample FLA (and any support files) that I could publish and see the issue for myself? Something super simple - doesn't need to be your production files.

 

You're using the latest version of TransformManager, right?

Link to comment
Share on other sites

Yup! Upgraded to the latest version and still seeing it. Do you have a Private Message I can send the files to?

Link to comment
Share on other sites

Sure, send me a private message or e-mail. questions -at- greensock.com

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×