Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Handycam

Transform Manager ignore bounds?

Recommended Posts

I seem to remember a way to allow object in the TM to not be constrained by the size of the TM instance; that is, they are free to bleed off the edges. For the life of me, I can't find the property. What is it?

Link to comment
Share on other sites

You could just set the "bounds" to null. Is that what you're talking about?

Link to comment
Share on other sites

Tried that, did not work. Also the ASDOCs say null is the default anyway.

 

To do it, I had to set a rectangle that is much larger than the container the TM is in or the TM itself, and set the bounds to that.

 

[bindable] private var myrect:Rectangle = new Rectangle(-2000,-2000,4000,4000);

Link to comment
Share on other sites

You must be using FlexTransformManager, right? By default, that automatically sets the bounds to the size of the FlexTransformManager instance in order to avoid bugs in the Flex framework that can cause funky behavior with scrollbars. Again, this has nothing to do with FlexTransformManager - it's a bug in Adobe's Flex framework and the automatic bounds setting is meant to help. But if your big Rectangle solution worked, super. Thanks for letting us know.

Link to comment
Share on other sites

Yes, it is Flex. Good to know, thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×