Jump to content
GreenSock

khw2010

COM folder not working

Recommended Posts

Not sure if "the tweening" portion of the forum is appropriate for this q, but here goes:

 

I've been working w. TweenMax for a few months now (LOVE IT), however, for some reason I'm having some rather interesting problems related to my "com" folder. FYI, for each new project I copy the "com" folder into each new project folder and begin working with a new flash file (which is saved within said new project folder). For some reason my most recent project has been hit with several errors all indicating that the com folder cannot be located (see below):

 

Scene 1, Layer 'actions', Frame 1, Line 1 1172: Definition com.greensock could not be found.

Scene 1, Layer 'actions', Frame 1, Line 2 1172: Definition com.greensock.easing could not be found.

Scene 1, Layer 'actions', Frame 1, Line 3 1172: Definition com.greensock.plugins could not be found.

Scene 1, Layer 'actions', Frame 1, Line 4 1172: Definition com.greensock.loading could not be found.

Scene 1, Layer 'actions', Frame 1, Line 5 1172: Definition com.greensock.events could not be found.

Scene 1, Layer 'actions', Frame 1, Line 1 1172: Definition com.greensock could not be found.

Scene 1, Layer 'actions', Frame 1, Line 2 1172: Definition com.greensock.easing could not be found.

Scene 1, Layer 'actions', Frame 1, Line 3 1172: Definition com.greensock.plugins could not be found.

Scene 1, Layer 'actions', Frame 1, Line 4 1172: Definition com.greensock.loading could not be found.

Scene 1, Layer 'actions', Frame 1, Line 5 1172: Definition com.greensock.events could not be found.

 

For all intents and purposes the file should be located, I've done nothing different in creating new projects, so can't for the life of me understand -- what gives? Incidentally, workaround this time was to save my new flash file in an old project folder.

 

Also, for your info, this is what my project folder looks like:

 

com // the come folder

Lesotho2020.fla // the flash file

 

Any help is greatly appreciated!

Link to comment
Share on other sites

Are you sure that you put the right "Source Path"?

 

in the properties panel, have a button "Action Script settings"... Is the "com folder" in this path?

 

 

Hope that's helpfull =D

Link to comment
Share on other sites

Did you change the name of the main folder or directory? I had the same problem, and realize that I'd renamed the containing folder — that caused the problem.

Link to comment
Share on other sites

  • 11 months later...

I'm having the same issue, and it is in my source paths.

 

It just keeps saying; Definition com.greensock could not be found, and it always appears twice for the same line....

Any thoughts?

Link to comment
Share on other sites

Hello,

 

Sorry to hear you are having trouble. I vaguely remember experiencing something like this once or twice. It's definitely something to do with Flash. I recall one of the following helping:

 

-saving your fla to a new folder that contains the com folder

-saving youf fla with a new name

-create a new fla

 

make sure your source path doesn't point to com. it should point to the folder that contains com.

 

also I rarely ever have to ever touch the source / class path if my com folder is in the same folder as the fla.

 

if none of that works, please upload a simple example that illustrates the problem. We might then be able to narrow it down to your machine or Flash Pro.

 

also it can't hurt to download a fresh version of the Tweening Platform.

 

-carl

Link to comment
Share on other sites

In Flash have you set up your paths correct? On the main bar, screen right, next to the stage size params there is a little Spanner icon (all from my head this is, so it may be slightly off). Click that, you'll get all the info about your FLA and how it'll compile etc. Anyway, in there you can set up where your external libraries are. Put the com folder into a folder called something like Actionscript on the root of your drive or wherever you are happy to have it, and add that folder to the libraries list.

Link to comment
Share on other sites

Thanks!

I pointed it straight to the .com folder not thinking....

Fixed, and works now!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×