Jump to content

Esben Juul Mortensen

GSAP business and npm/yarn registry auth on Netlify

Recommended Posts

Has anyone ever gotten this to work ever?…I see a couple of threads on it, but it seems no matter what I do it doesn't work.

I have Netlify setup so it uses the exact same Node version and Yarn version as I do locally. I even hardcode the authToken in .npmrc but is still doesn't work. I currently have:


I've also tried adding .yarnrc, environment variables…you name it - I've tried it.

Link to comment
Share on other sites

Heya! Super annoying. Sorry to hear.

But yep it is possible to get it to work, it seems like there are specific combinations of setups that cause issues sometimes. I personally use Netlify with netlify env vars and npm without issues.

Maybe this blog post will help?



Give it a bash and if not we'll step through it together until it's working!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.