Jump to content
GreenSock

wpsoul

Stagger with .from and opacity is broken in last gsap update

Recommended Posts

I continue to get a lot of issues with stagger in last update. I found that when I have several animations on page with ScrollTrigger + stagger + .from direction, then it works really bad. Sometimes it loads correctly, sometimes it doesn't hide element (even those which are not in first screen), sometimes animation is not finished.

 

What was changed in last update for staggers?  3.10 version - hide element before animation, it's correct. 3.11 - sometimes it hides, sometimes it doesn't

 

 

See the Pen yLjaMxv by igor-sunz (@igor-sunz) on CodePen

See the Pen JjvRQrN by igor-sunz (@igor-sunz) on CodePen

  • Like 1
Link to comment
Share on other sites

Hi @wpsoul,

 

I've notified the upper floor in GSAP tower about this, so stay tuned. 

 

In the mean time this seems to be working as you expected:

See the Pen ZEopdrQ by rhernando (@rhernando) on CodePen

 

Happy Tweening!!!

Link to comment
Share on other sites

Can you try this URL:
https://cdpn.io/pen/debug/ZEopdrQ

 

That's the codepen without any iframes and stuff like that.

 

In Ubuntu 22 and 20 it's working fine on the latest Chrome and Firefox.

  • Like 1
Link to comment
Share on other sites

P.s. It doesn't work also on Iphone. Also, sometimes it doesn't work properly on Firefox, but not so often like on Chrome

Link to comment
Share on other sites

P.s2 It doesn't work now also on Incognito mode. For me, it looks like GSAP has some inner cache now and it doesn't work properly. Because this bug can be visible not on first load, but when you reload page several times

Link to comment
Share on other sites

Yep it's really weird, first I though everything was working fine like @Rodrigo said, but it is the first time when you open the codepen everything with `.split` class is visible only if you scroll and refresh the page will it work as expected. Don't know if it is only on Codepen. Tested on Safari Version 15.5 (17613.2.7.1.8) macOS 12.4 (21F79).

 

 

Edit: It also happens in Chrome Version 105.0.5195.102 (Official Build) (x86_64) and I've also downloaded the pen (lower left > export > download .zip) and opened the index.html file in Safari and Chrome and there it also happens, so it is not Codepen

Link to comment
Share on other sites

Looking into it. I'll post back when I have more information. 

  • Like 2
Link to comment
Share on other sites

Can you please confirm that the problem goes away if you set lazy: false on the .from() tween?:

See the Pen GRdrJPW by GreenSock (@GreenSock) on CodePen

  • Like 1
Link to comment
Share on other sites

@GreenSock I can confirm that it's working properly for me. Do we need to use lazy parameter now on all staggers with .from?

  • Like 1
Link to comment
Share on other sites

No, this doesn't mean you'll have to do that in the future. I'm just trying to narrow down the issue. In the CURRENT version, you could use this as a workaround but my goal is NOT to require it after a patch. 

  • Like 1
Link to comment
Share on other sites

Here's a fork that loads the beta version of the upcoming release - can you please confirm that it fully resolves the issue(s) for you (without setting lazy: false)?: 

See the Pen bGMgZda?editors=1010 by GreenSock (@GreenSock) on CodePen

  • Like 2
Link to comment
Share on other sites

@GreenSock Can I use beta version on production or it will have more changes in stable version?

Link to comment
Share on other sites

Sure, you are welcome to use that. I am not aware of any problems in that beta version. It may end up having a few more tweaks before release but I'd certainly consider it an improvement over 3.11.1 since it addresses several bugs (which of course we didn't know about when it was released).

 

Let us know if you run into any problems at all. Enjoy!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×