Jump to content
GreenSock

Frederikvdbe

CI/CD build keeps failing

Recommended Posts

My buddy.works CI/CD keeps failing over the gsap package.

I use the instructions provided on my dashboard under CI/CD:

  • .npmrc file with provided auth token
  • the build step to install npm packages (npm install gsap --registry https://npm.greensock.com)

 

The latest error I'm getting is:

npm ERR! 403 403 Forbidden - GET https://npm.greensock.com/@gsap%2fbusiness/-/business-3.11.0.tgz - You must be logged in to install/publish packages.
npm ERR! 403 In most cases, you or one of your dependencies are requesting
npm ERR! 403 a package version that is forbidden by your security policy, or
npm ERR! 403 on a server you do not have access to.

 

Anyone any idea why this is hapening?

 

Thanks in advance!

 

Link to comment
Share on other sites

Hi there! You're business green so you'll need to run this command the first time -

npm install gsap@npm:@gsap/business

Link to comment
Share on other sites

Hi Cassie, thank you for your response but I'm getting the same error. Screenshots for reference.

 

 

16860187_Screenshot2022-08-25at15_41_54.thumb.png.aeb9ac9538ef95171c42b24c3f785044.png

Screenshot 2022-08-25 at 15.42.08.png

Link to comment
Share on other sites

Hi @Frederikvdbe. Here's a post with instructions that may be helpful: 

 

Your .npmrc file should have: 

always-auth=true
@gsap:registry=https://npm.greensock.com/
//npm.greensock.com/:_authToken=${NPM_TOKEN}

 

 

Link to comment
Share on other sites

Hi @GreenSock, thank you for your reply but I've tried everything, the instructions on the GS dashboard, the instructions mentioned in the Netlify toppic and still get the same error...

 

Console output for reference:

npm install gsap@npm:@gsap/business
npm WARN deprecated source-map-url@0.4.1: See https://github.com/lydell/source-map-url#deprecated
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated source-map-resolve@0.5.3: See https://github.com/lydell/source-map-resolve#deprecated
npm WARN deprecated chokidar@2.1.8: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
npm WARN deprecated stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated svgo@1.3.2: This SVGO version is no longer supported. Upgrade to v2.x.x.
npm ERR! code E403
npm ERR! 403 403 Forbidden - GET https://npm.greensock.com/@gsap%2fbusiness/-/business-3.11.0.tgz - You must be logged in to install/publish packages.
npm ERR! 403 In most cases, you or one of your dependencies are requesting
npm ERR! 403 a package version that is forbidden by your security policy, or
npm ERR! 403 on a server you do not have access to.
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2022-08-30T07_26_12_662Z-debug.log
Action failed: see logs above for details
Container exited with status code other than 0

 

Link to comment
Share on other sites

Hi there!

 

Can you try doing this: Delete the .npmrc file in the project then run the following commands (don't forget to replace the <your-auth-token> with the correct token

 

$ npm config set @gsap:registry https://npm.greensock.com/
$ npm config set //npm.greensock.com/:_authToken <your-auth-token>
$ npm install @gsap/business
$ npm install gsap@npm:@gsap/business

 

 

 

Link to comment
Share on other sites

Hi @Cassie thank you for your help so far. I've tried your command and I still get the same error... However, I just tried creating a new pipeline on buddy and just ran your command nothing else and the npm commands ran fine... Any idea on how this can happen? Why my build that ran fine before is now broken and why it keeps getting 403 errors?

Link to comment
Share on other sites

Ok I figured it out. I tested the options suggested above on a new pipeline and there everything worked fine so after some fiddling around I saw I used to ran the npm command from a template 'Gulp' action whereas on the new pipeline I used a 'Node' template action to first install gsap and now everything works as expected! Thank you @Cassie and @GreenSock for your help and patience! 

  • Like 2
Link to comment
Share on other sites

Build tools are a curse sometimes. It's so hard for us to help too which is super frustrating for everyone. We appreciate your patience!

💚 Thanks for popping back to let us know you fixed it!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×