Jump to content
GreenSock

perry.biava

Unsatisfied version 3.10.4 from shell of shared singleton module gsap (required =npm:@gsap/business@3.10.4)

Recommended Posts

I am having trouble installing gsap business green in an Angular 14 application. Previously I had no trouble running gsap public. But I wanted to us MorphSVG so I purchased a business green license. This is the procedure I followed:

1. Deleted node_modules

2. Deleted yarn.lock

3. Deleted gsap in package.json

4. added .npmrc file with the proper syntax and authorization token

//npm.greensock.com/:_authToken=<my authtoken>
@gsap:registry=https://npm.greensock.com

5. ran a yarn cache clean

6. ran a yarn install

7. Ran installation code from dashboard with a the version of @3.10.4 added and a network-timeout parameter of 100000

                  yarn add gsap@npm:@gsap/business@3.10.4 --network-timeout 100000

8. I ran the application and I get this error message:

 

image.png.771825f94b89b63d0dac453d4a2e2472.png

 

9. I have included my typescript file and the package.son

sidenav.component.ts package.json

Link to comment
Share on other sites

Hi there! Thanks for joining Club GreenSock. Sorry to hear about this. Sounds super frustrating. There's a known bug with yarn and private repos (nothing to do with GSAP) That may be the issue here?

If so, there's a thread here with a lot of good information on yarn

 

 

I hope this helps!

  • Like 2
Link to comment
Share on other sites

I am getting the same error with npm

Link to comment
Share on other sites

Yep, that was it. 

 

I have a micro-frontend platform with all the MFEs built in Angular 14. For anyone else with the same problem, this is what fixed it:

 

Additionally, checkout: "Remarks on shareAll" at Angular Architects: https://www.angulararchitects.io/en/aktuelles/whats-new-in-angular-architects-module-federation-14-3/

 

Thanks for all the help, much appreciated.

 

 

 

 

 

Unrecognized-Version-Fix.png

  • Thanks 1
Link to comment
Share on other sites

Thanks for sharing your solution! 🙌

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×