Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
sayan5561

Getting some sticky animation when I am using locomotive scroll and scroll trigger

Recommended Posts

This is my first time trying scroll trigger in gsap I am trying to understand how locomotive scroll and scroll trigger work together but when the animation is going on I am facing some kind of sticky-ness in the animation I mean the animation is not smooth there some kind of delay in between but I don't know what is the reason for this. I tried to recreate this situation in my code pen which I have linked below. It will be helpful if some one can help me to solve this. thank you

See the Pen jOYvYxK by sayan-chatterjee5132 (@sayan-chatterjee5132) on CodePen

Link to comment
Share on other sites

Welcome to the GSAP forum @sayan5561

 

You've got an unspecified transition set on your h4 - so basically a transition all - in CSS, which is interfering with GSAP's tween.

 

You will need to either get rid off it or specify what is supposed to be transitioned, so it does not add CSS transitions to properties you are going to tween on with GSAP on those elements.

 

Edit: This here explanation by @GreenSock should help understand the why behind your issue a bit better.

 

 

Happy tweening!

 

See the Pen WNdgMZW by akapowl (@akapowl) on CodePen

 

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

yup thats solves it thank you very much

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×