Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
jacksmug

ScrollTrigger.min.js got error and site is broken

Go to solution Solved by OSUblake,

Recommended Posts

Hey guys, I need your help and maybe it's quite general issue. After a long time I am not touching my project, my project is broken and got an error inside 'Console'.

Here's the error:
image.thumb.png.60145f114ff3278705f8b04393702d00.png

I cannot scroll down my page and seems like ScrollTrigger is not functioning.
Not sure what happened. I am using ScrollTrigger version 3.10.0 and I tried to update to latest version. Still get this issue.

Link to comment
Share on other sites

Hi jacksmug,

 

What makes you think you it's a ScrollTrigger issue? It says resetTo is not a function, but there nothing in the ScrollTrigger's code that makes such a call, so your error is probably happening elsewhere. That image also shows smooth-scrollbar. You might want to check with that. The best way to figure out an error like that is to isolate it by disabling parts of your code until you find the problem.

 

  • Like 2
Link to comment
Share on other sites

  • Solution

Hi @jacksmug

 

Can you verify the URL you are using for ScrollTrigger? It sounds like you might using a beta version, possibly from CodePen. Make sure you are using the ones hosted on CDN, like cdnjs. It should be at version 3.9.1 now.

 

https://cdnjs.com/libraries/gsap

 

Link to comment
Share on other sites

Yep, it definitely sounds like you're using the BETA version from the CodePen CDN which is NOT intended to be deployed anywhere or used in production. It's tapping into an unreleased feature in an upcoming GSAP release :)

 

Like Blake said, you should definitely be using the official CDNs, not the beta. 

  • Like 1
Link to comment
Share on other sites

8 hours ago, OSUblake said:

Hi @jacksmug

 

Can you verify the URL you are using for ScrollTrigger? It sounds like you might using a beta version, possibly from CodePen. Make sure you are using the ones hosted on CDN, like cdnjs. It should be at version 3.9.1 now.

 

https://cdnjs.com/libraries/gsap

 


Yes, i'm sorry that i've been using CDN from this codepen example. The issue now fixed already by updating to latest CDN.

See the Pen oNLqgBm by GreenSock (@GreenSock) on CodePen


Thank you @OSUblake & @GreenSock(Jack)!

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×