Jump to content
GreenSock

krissss

gsap-bonus.tgz prevents private npmjs package from installation

Recommended Posts

Hello network !

gsap version: 3
I'm experiencing some issues with gsap-bonus.tgz with yarn. The packages im trying to install are from monorepo, or basically they present a custom framework. Since i devided them into private packages in npmjs, when i try to run yarn command to install these packages, the package which includes gsap-bonus.tgz throws an error:


error "packages/app/gsap-bonus.tgz": Tarball is not in network and can not be located in cache (["C:\\Users\\Kristiyan\\Documents\\GAMES\\leprechaun-respins\\packages\\app\\gsap-bonus.tgz","C:\\Users\\Kristiyan\\AppData\\Local\\Yarn\\Cache\\v6\\.tmp\\666fb417fd4c77f48a6f166bd0b8e500\\.yarn-tarball.tgz"])

The gsap-bonus.tgz file started making problems since we published the private packages in npmjs.
This is how the package.json file dependencies looks like inside the game im trying to develop (gsap-bonus.tgz is inside @silverbackgmng/app) :

  "dependencies": {
    "@silverbackgmng/app": "^1.0.70",
    "@silverbackgmng/config": "^1.0.40",
    "@silverbackgmng/contracts": "^1.0.50",
    "@silverbackgmng/engine": "^1.0.50",
    "@silverbackgmng/localization": "^1.0.30",
    "@silverbackgmng/manifest": "^1.0.1",
    "csvjson-csv2json": "^5.0.60"
  }

and this is the package.json file dependencies inside @silverbackgmng/app private package:
 

  "dependencies": {
    "@silverbackgmng/engine": "^1.0.22",
    "@silverbackgmng/slot": "^1.0.11",
    "@silverbackgmng/ui": "^1.0.26",
    "@types/howler": "2.2.1",
    "@types/webpack-env": "1.16.0",
    "eventemitter3": "4.0.7",
    "gsap": "file:gsap-bonus.tgz",
    "howler": "2.2.1",
    "lerna": "^4.0.0",
    "pixi-viewport": "4.18.1",
    "pixi.js-legacy": "5.3.3"
  }

Do you have any suggestions why that issue occurs?
 

Link to comment
Share on other sites

  • krissss changed the title to gsap-bonus.tgz prevents private npmjs package from installation

I'm afraid I'm not able to help here, Maybe @OSUblake can help?

Link to comment
Share on other sites

14 minutes ago, Cassie said:

Maybe @OSUblake can help?

 

Don't use yarn. 🤷‍♂️

 

It sounds like it's trying to install from a local cache or mirror. Searching for that error on Google is probably your best bet. Maybe these might offer some help.

https://github.com/yarnpkg/yarn/issues/2861

https://github.com/yarnpkg/yarn/issues/2920

https://stackoverflow.com/questions/67479816/deploy-gatsby-to-vercel-with-local-package-dependency

 

 

 

  • Like 1
Link to comment
Share on other sites

After 2 days of fighting the issue this is the solution for me:
when publishing a package, i was using

yarn publish

command, which seems to make a local cache while publishing, and when someone tries to install the published packages, the error occurs.
Using

npm publish

fixes the issue for me.

So @OSUblake was right,

Quote

Don't use yarn. 🤷‍♂️

haha
 

Cheers!
 

Link to comment
Share on other sites

1 minute ago, krissss said:

Using

npm publish

fixes the issue for me.

 

So I was right... don't use Yarn. 🤣

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×