Jump to content
GreenSock

Ali Manuel

The code works normally on codepen but locally nothing works " ScrollTrigger"

Recommended Posts

It's hard to say without seeing your local setup. Are you loading your scripts last, and not in the head?

 

  • Like 2
Link to comment
Share on other sites

11 hours ago, OSUblake said:

It's hard to say without seeing your local setup. Are you loading your scripts last, and not in the head?

 

at last of the page , the code works without scrolling ,here is the problem

Link to comment
Share on other sites

I'll echo what @OSUblake and @Visual-Q said. This is pretty hard to debug without a look at your setup.

Are there any errors in the console?

Link to comment
Share on other sites

14 minutes ago, Cassie said:

I'll echo what @OSUblake and @Visual-Q said. This is pretty hard to debug without a look at your setup.

Are there any errors in the console?

Hello @Cassie , nothing in the console , also the website works with gsap nroamlly ,i made a lot of animation in the same website via gsap.

Link to comment
Share on other sites

If it's working in codepen but not on your local site and there's no errors, I'm not really sure what we can do I'm afraid.

Typo? Conflicting class names/timeline naming? Incorrect loading of scripts or resources? Caching? 

My advice would be to strip the code down to the most basic bits until it works and layer up again.

Sorry I can't be of more help!

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×