Jump to content
GreenSock

goooon

ScrollTrigger vertical scroll pin-spacer problem

Recommended Posts

Hello. can't figure out how to fix this.

I searched the forum, but did not find exactly this problem. And what I did find I didn't really understand.


If pinSpace: True,  I have a huge padding below section 2. 
If pinSpacefalse, the spacer exceeds the section 3.

 

*The reason why I give so much height to section 2 is to slow down the animation. 

 

Can you help me? 

 

See the Pen gOmOxze by Gon82 (@Gon82) on CodePen

Link to comment
Share on other sites

Hi @goooon,

 

Remove your height setting for section2, then use end: '+=600%', pinSpacing: true,

 

The percentage for the end value is viewport heights so that'd give you the same effect without overlapping section 3.

  • Like 3
Link to comment
Share on other sites

Amazing. I can't believe it.

 

@elegantseagulls.

Thank you so much! 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×