Jump to content

Jung von Matt NECKAR

GSAP private module + Netlify + yarn

Recommended Posts

Hi, is there a way to deploy to vercel using yarn? Tried the netlify way on vercel(using a env variable for my token), couldn't make it work, I get a Request failed: 403 forbidden . Thanks.


Finally deployed to vercel with yarn following @Prasanna instructions on page 1. 
Just a tip, don't add the .yarn/releases folder to the .gitignore(add the cache though, as it's quite a few mb), as then the build will fail.




  • Like 1
Link to comment
Share on other sites

  • 1 month later...

@Prasanna Someone at work actually uses Ubuntu and it's having issues with this. When running yarn add @gsap/shockingly it gives the following error:

➤ YN0027: @gsap/shockingly@unknown can't be resolved to a satisfying range
➤ YN0035: The remote server failed to provide the requested resource
➤ YN0035:   Response Code: 404 (Not Found)
➤ YN0035:   Request Method: GET
➤ YN0035:   Request URL: https://registry.yarnpkg.com/@gsap%2fshockingly

Also a message to my fellow GreenSockers, running this yarn add gsap@npm:@gsap/shockingly, result in this error as well in Ubuntu:

➤ YN0000: ┌ Resolution step
➤ YN0001: │ Error: gsap@npm:@gsap/shockingly isn't supported by any available resolver
    at pd.getResolverByDescriptor (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:432:5658)
    at pd.bindDescriptor (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:432:5047)
    at I (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:441:6932)
    at async Promise.all (index 0)
    at async Ke.resolveEverything (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:441:8197)
    at async /home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:444:2138
    at async Fe.startTimerPromise (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:412:3730)
    at async Ke.install (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:444:2077)
    at async /home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:449:122
    at async Function.start (/home/nidhal/.node/corepack/yarn/3.1.1/yarn.js:412:2287)
➤ YN0000: └ Completed
➤ YN0000: Failed with errors in 0s 7ms

I don't know if this is related to the version of yarn that He has installed in his machine (I believe is 3.1.1), but while installing stuff in linux is a bit different that win/mac the resulting installed resource should be the same.


Also is worth noticing that we're not using netlify for this, we're deploying on digital ocean using a docker image. For now we'll use the .tgz file and since is a private repo, there isn't a lot of issues with it, but it would be great to have a notion of what's the issue here.


I did a search in the issues at Yarn's repo and didn't found anything so I'll create a ticket there and give feedback regarding this.


Cassie, Jack. I don't know if this is the right place for this, since my issue is not related to Next and Netlify, if you want I can create a new thread in the forums specific for this.




  • Thanks 1
Link to comment
Share on other sites

Thanks @Rodrigo. Hopefully @Prasanna will have some feedback - all I know is that Yarn has been problematic for a long time with various known bugs (on their end). We typically recommend switching to NPM which has broad support and appears to be better maintained. 🤷‍♂️

Link to comment
Share on other sites

@Rodrigo thanks for reporting. It seems like you might have missed configuring the scoped registry on the machine. This can be resolved by running these commands:

$ npm config set @gsap:registry https://npm.greensock.com/
$ npm config set //npm.greensock.com/:_authToken xxxx-xxxx-xxxx-xxxx
$ yarn add @gsap/shockingly gsap@npm:@gsap/shockingly


Running the above commands should help. If you still face issues then I can help you by providing a sample yarn configuration file (for yarn berry).

Here are some additional resources that could be helpful:



  • Like 4
Link to comment
Share on other sites

On 12/18/2021 at 11:20 PM, elegantseagulls said:

Will try this Monday!

We were able to get this working with our setup (but forgot to respond here right away). Thanks for all your insights and help @Prasanna!

  • Like 1
Link to comment
Share on other sites

@Prasanna Thanks for the follow up.


Actually we already have updated the .npmrc file and the global configs. The global .npmrc file looks like this:


As I mentioned this is happening on the local dev environment for a Next app on Ubuntu 20.04 using Yarn 3.1.1, on a Win 10 machine using Yarn 1.22.5 works as expected.


Over the weekend I took the time to install Ubuntu 20.04 here at home and I'm seeing the same issue. This is the result:

rodrigo@rodrigo-desktop:~/Web Apps/GSAP/yarn-bonus$ yarn add @gsap/shockingly gsap@npm:@gsap/shockingly
➤ YN0027: @gsap/shockingly@unknown can't be resolved to a satisfying range
➤ YN0035: The remote server failed to provide the requested resource
➤ YN0035:   Response Code: 404 (Not Found)
➤ YN0035:   Request Method: GET
➤ YN0035:   Request URL: https://registry.yarnpkg.com/@gsap%2fshockingly

➤ Errors happened when preparing the environment required to run this command.

I created a simple project using yarn init without any dependencies and the results are the same. No issues in Win 10/Yarn 1.22.5 and the same error in Ubuntu 20.04/Yarn 3.1.1.


If I have time I'll see if I can remove yarn and install the latest 1.x version (which is no longer supported though) and see if it works with that.


Finally I created an issue in Yarn, but it was marked as unreproducible by the bot so I don't know what amount of attention it'll attract:





Link to comment
Share on other sites

@Rodrigo It seems like the greensock registry was not set for the computer. How about we debug this over google meet?

Link to comment
Share on other sites

Hi, I have been trying to upload the package to vercel without succeed. I decided to report the issue in this forum because I've read all the entries and tried everything but no result.


Here's my .npmrc





and the last log I got from vercel...


[log] Downloading files...
21:30:38.159 [log] Working directory: /vercel/path0
21:30:38.164 [log] Using npm
21:30:38.164 [log] Found NPM_AUTH_TOKEN or NPM_TOKEN in environment; creating .npmrc
21:30:38.167 [info] Prepare build took: 6.896855 ms
21:30:38.167 [log] ----------------- Install devDependencies -----------------
21:30:42.065 npm ERR! code E404
21:30:42.072 npm ERR! 404 Not Found - GET https://registry.npmjs.org/@gsap%2fshockingly - Not found
21:30:42.072 npm ERR! 404
21:30:42.072 npm ERR! 404 '@gsap/shockingly@^3.9.1' is not in the npm registry.
21:30:42.072 npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
21:30:42.072 npm ERR! 404 It was specified as a dependency of 'path0'
21:30:42.073 npm ERR! 404
21:30:42.073 npm ERR! 404 Note that you can also install from a
21:30:42.073 npm ERR! 404 tarball, folder, http url, or git url.


best regards!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.