Jump to content

Search In
  • More options...
Find results that contain...
Find results in...

Has anyone been rejected by AdWords for using gsap3?

Recommended Posts

For my new ads tried to use gsap3. Of course used the script link, that Google is providing (https://s0.2mdn.net/ads/studio/cached_libs/gsap_3.0.1_min.js).

Checked the banner through the html5validator, everything was fine. Banners were sent to Google. After few hours banner was rejected with "Invalid Fourth-Party Call" reason. When gsap version was changed to the 2nd everything was fine. It happened with Google Ireland. Bthw, google web designer ad also failed, when gsap was inserted through the app menu. Of course they don't want to hear anything, even if sending links to official google documentations (like hosted libs) and I understand that nothing can't be done at the moment. Just want to know if anyone had something similar. 

Link to comment
Share on other sites

I haven't heard of anything like that, no. Have you contacted the Google folks about that at all? Do you know exactly why they're getting rejected or what "Invalid Fourth-Party Call" means? 

Link to comment
Share on other sites

I'm having conversation with Google team, it looks like there's an issue in Google Ad. Once I will have more information I will get back here. 

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

Some updates:

Banners created in GWD (Google web designer) also are disapproved when GSAP library is inserted (via GWD menu "Click File > Include JS library > GreenSock." as mentioned in official documentation).

Of course all ads are tested in official google html5 ad validator, and they all pass it. Banners were tested also with Google Ads team and they agree, that ad is made correctly. But they try to understand why they are still disapproved in their system. We had phone conversations, tons of e-mails. Looks like an interactive ping-pong game. Looks like there's an error inside their own system, which is checking ads before pushing they live. 

By the way, when my problem reached Google Ads team, they updated hosted library to the latest gsap. Unfortunately this link is still not white-listed in the system where our ads are going to. 

Link to comment
Share on other sites

  • 2 weeks later...

I am having the exact same problem will revert back to GSAP2 i have never had this problem across hundreds of banners the first time i use GSAP3 i am getting invalid fourth party call. Will keep you updated to the outcome.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.