Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Daniel2024

Console is returning: Failed to load gsap.min.js.map

Recommended Posts

Hello guys,

 

I have included gsap.min.js in a folder. After taking a look in the console, I noticed that I am getting the notification that the gsap.min.js.map file failed to load (404).

I am confused about this error, because I just included gsap.min.js in my folder and not .map file.

What is wrong here?

 

Thank you in advance.

 

Regards Daniel

 

 

Link to post
Share on other sites

Hey Daniel,

 

That's a weird error. Are you using a build tool? How are you loading GSAP? Can you reproduce the issue using the same setup on something like StackBlitz? 

Link to post
Share on other sites

Hi Zach,

 

no, I use vs-code.

I downloaded gsap and embedded it locally.

I also embedded:

 

<script src="./js/gsap.min.js"></script>

<script src="./js/scrollmagic/ScrollMagic.min.js"></script>

<script src="./js/scrollmagic/animation.gsap.js"></script>

<script src="./js/main.js"></script>

 

in the same sequence like above.

Link to post
Share on other sites

I'm not sure what could be causing that error. Can you please make a ZIP file of your project so that we can take a closer look at what's going on? I can't reproduce the error just by loading those files on my side.

  • Like 2
Link to post
Share on other sites
6 hours ago, Daniel2024 said:

I am confused about this error, because I just included gsap.min.js in my folder and not .map file.

 

Just put the map file in your js folder. You don't have to do anything else.

  • Like 1
Link to post
Share on other sites

it seems that the data is too big in my folder. Is there any other way to upload it?

 

Link to post
Share on other sites

You can find some of the map files here. 

https://github.com/greensock/GSAP/tree/master/dist

 

47 minutes ago, Daniel2024 said:

it seems that the data is too big in my folder. Is there any other way to upload it?

 

Put it on GitHub. We don't need to see your project. Just enough to reproduce the error.

 

I don't know why your setup is trying to load it though. The map files are only used for errors. Maybe the problem is ScrollMagic. It hasn't been updated to work with v3.

https://github.com/janpaepke/ScrollMagic/pull/920

 

Link to post
Share on other sites

Where's your html, css, and other js files? We should be able to download your project, fire up a server, and see the problem.

Link to post
Share on other sites
13 hours ago, OSUblake said:

We don't need to see your project. Just enough to reproduce the error.

 

Clarification. I meant that we do not need to see your entire project. Just a simple project that clearly shows the error. The less, the better.

Link to post
Share on other sites

The problem is solved. I putted the .map-file in the same folder as gsap.min.js!

 

 

  • Like 1
Link to post
Share on other sites
3 minutes ago, Daniel2024 said:

The problem is solved. I putted the .map-file in the same folder as gsap.min.js!

 

Cool! Quick question, were you using a server/framework, and if so what e.g. node, express, apache, wordpress, etc?

 

I'm just wondering what was making it show the 404, because I don't think that should happen by default.

Link to post
Share on other sites

I was running my project on localhost and I was using only greensock and scroll magic.

Now im facing the problem that probably scrollMagic isn't working. I have made several animations but now on one page the animations cant be executed.

 

"Maybe the problem is ScrollMagic. It hasn't been updated to work with v3."

 

How can I solve this?

Link to post
Share on other sites
6 hours ago, Daniel2024 said:

How can I solve this?

Impossible for us to say given the lack of code to reproduce the issue.

 

ScrollMagic isn't a GreenSock product anyway - you might get a clearer answer by posting an issue on the ScrollMagic repo.

Link to post
Share on other sites

im getting these errors:

 

[Warning] Invalid property – "opacity" – "set to" – 0 – "Missing plugin? gsap.registerPlugin()" (gsap.min.js, line 11)
[Warning] Invalid property – "y" – "set to" – 35 – "Missing plugin? gsap.registerPlugin()" (gsap.min.js, line 11)
[Warning] GSAP target null not found. https://greensock.com (gsap.min.js, line 11)

Link to post
Share on other sites

This doesn't help - we'd need to see your code in context. All you shared are some library files which aren't the problem. Can you please share an actual project that clearly shows the problem (with as little code as possible)? We need to be able to run it in the browser and actually see the errors in the console for ourselves please. But again, we can't support ScrollMagic specifically here, as it's not a GreenSock product. If there are any GSAP-specific questions, though, we'd be happy to help. 

Link to post
Share on other sites

I had to deal with this "issue" as well, I didn't go through entire code but for some reason ScrollMagic tries to update tween twice, then detects it as overwrite and tries to call onOverwrite method which has been removed from gsap 3. Certainly not related to GSAP and those are just warnings, you can ignore them without any issue. There are other compatibility issues, for example ScrollMagic tries to use 'Tween' object when you try to update scene duration on the fly, this gives error. You can set Tween equal to gsap directly in ScrollMagic files.

  • Like 1
Link to post
Share on other sites

I was having the same issue with the gsap.min.js.map file. After downloading it and throwing it in the GSAP local folder all is well. Now I'm facing the same issue with GSDevTools.min.js.map. Any chance of getting that too?

 

For context: I'm developing in the Intellij IDEA IDE which uses the Python SimpleHTTPServer for local testing. I only have the issue occurring when running my project in localhost. It randomly shows "pending" status for various files when I try to load the project.

Link to post
Share on other sites

Hey @Chris Manuel. The latest version of the ZIP file has all map files included. Just download the ZIP again :) Your account dashboard is a good place to find the ZIP download.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×