Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Mike D

xPercent, yPercent outputting pixel values

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi all,

 

I'm running GSAP v1.19.x and according to the docs x/yPercent has been supported since 1.13.x. What's strange is I created a codepen with version 1.19.x and it works just fine. The ask here I guess is - what, if anything, in the way of css styles or tween attributes could override or somehow prevent x/yPercent from outputting percentages?

 

Thanks and sorry kind of a random question here.

 

Link to comment
Share on other sites

One other note, I'm using TimelineLite in my app, and I also used TimelineLite in my codpen - where things are working fine.

Link to comment
Share on other sites

Hm, that's really tough to diagnose blind. Got a demo somewhere we can peek at? 

 

I'm having a really difficult time thinking of what'd be getting in the way unless you're targeting the wrong element or something(?)

 

Or maybe you're using a really old version of CSSPlugin but a newer version of TimelineLite? I dunno. Once we see the problem in action, it'll be much easier to diagnose. Have you tried updating to 2.0.2?

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×