Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Filip Winiarski

Stuttering Animation Bug

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi, I am working on my site and since gsap 2.0.0 I have experienced very weird stuttering bug. Check the video below to see what's going on. Animations were playing flawlessly in gsap 1.x.

There are no elements on the page that could cover those blinking areas. I am using simple TimelineMax and TweenMax calls, up to 4 at the same time. (opacity, color and x/y positions).

Video: https://streamable.com/sjxrk
Did someone have similar issue?

Link to comment
Share on other sites

Hm, I can't imagine how GSAP could possibly make that happen, but I'd be happy to take at a reduced test case. Have you tried reverting to an older version to verify that it indeed resolves the issue? I wonder if it's more likely about an update to your graphics card driver or perhaps a browser update that caused the problem(?) 

 

I just can't fathom how any of the changes in 2.0 could affect things in that way, and nobody else has reported anything similar. But of course if there's a problem in the codebase, I'd want to fix it ASAP. 

  • Like 2
Link to comment
Share on other sites

30 minutes ago, GreenSock said:

Hm, I can't imagine how GSAP could possibly make that happen, but I'd be happy to take at a reduced test case. Have you tried reverting to an older version to verify that it indeed resolves the issue? I wonder if it's more likely about an update to your graphics card driver or perhaps a browser update that caused the problem(?) 

 

I just can't fathom how any of the changes in 2.0 could affect things in that way, and nobody else has reported anything similar. But of course if there's a problem in the codebase, I'd want to fix it ASAP. 


I have localized the issue. Stuttering was caused by animating super large fonts (the one in background). Still it is weird since I did not have the problem in 1.x. I have also upgraded to Angular 6 last week, which could also affect the rendering. Can't test with 1.x since it hasn't been working properly in Angular 6.

EDIT:
It's not even caused by the large font animation. Its own presence causes different animations to stutter T_T
I'm gonna switch to SVG or background image to walk around this issue.

Link to comment
Share on other sites

Yeah, please do let us know what you find. Like I said, I'm pretty confident this has nothing to do with GSAP but you've got me curious about the root cause of whatever you're running into there. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×