Jump to content


ScrollTo doesn't work on iPad 2

Moderator Tag

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi guys, GSAP rocks however, your ScrollTo plugin doesn't seem to work on iPad 2 upto date iOS.
NB this means the official GSAP ScrollTo example as presented does not appear to work.

Here is the GreenSock codepen that doesn't appear to work

Please can you let me know any work arounds ?

See the Pen LkOrKY by GreenSock (@GreenSock) on CodePen

Link to comment
Share on other sites

Hi @Gazzawazza :)


Sorry to hear you're experiencing a problem.


I can confirm what you're seeing. I thought perhaps it was a case of using up to date TweenMax and ScrollTo scripts, but that did not solve this issue for me. I tested on iPad 2/iOS 9.3 and iPad3/iOS 10.3 in both Chrome and Safari and got the same results. 


I think we'll have to kick this upstairs to @GreenSock for a closer look. Please stand by.


Link to comment
Share on other sites

Hm, when I first tried to look at that codepen on my iPad, it was a blank white screen. Weird. Once I took it out of codepen, it seemed to work fine. It was as if it was related to codepen and the way that it loads things into an iframe. Like Apple's ad blocker was kicking in maybe. Not entirely sure yet, but I had a few questions for you:

  1. Are you able to reproduce the problem OUTSIDE of codepen? And outside of an iframe?
  2. Do you see the totally blank screen like I did or are you seeing content on the page? 
  3. Have you tried setting autoKill:false? Apple has historically had bugs that mis-reported values during the animation, sometimes causing the autoKill to kick in.


  • Like 2
Link to comment
Share on other sites

hmmm... I think you're right Jack. This does look like a strange CodePen issue. I moved those pens over to a regular website and everything is just fine on my iPads. This is a bit weird as I'm almost certain I've tested some ScrollTo animations on CodePen and the iPad was fine. Maybe I'm just crazy. :blink:


Anyway, I'm blaming CodePen. All my other tests didn't produce any problems.


Happy tweening.


  • Like 1
Link to comment
Share on other sites

oh, BTW  - no I didn't see a blank screen in CodePen. It was just the regular content. Kind of weird.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.