Jump to content
GreenSock

TrinhVanDan

lagSmoothing doesn't work when not active tab?

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

I use tweenmax 1.20.2 to tween object in canvas. I use lagSmoothing to make sure the tween run when my tab is not active. but it doesn't work. It works with version 1.91.1.

here is my code: 

window.addEventListener('blur', function () {
    TweenLite.lagSmoothing(0);
}, false);


window.addEventListener('focus', function () {
    TweenLite.lagSmoothing(1000, 16);
}, false);

 

How to run with tweenmax 1.20.2. Thanks

Link to comment
Share on other sites

Ah yes, we added a conditional check in 1.20.0 so that when the tab/window is hidden, the ticker wouldn't be forced to wake up (which unintentionally made it act like lagSmoothing() was enabled when you returned). That should be resolved in the upcoming release which you can preview (uncompressed) at https://s3-us-west-2.amazonaws.com/s.cdpn.io/16327/TweenMax-latest-beta.js

 

Is that better? 

 

Thanks for letting us know about this. Sorry about any inconvenience. 

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×