Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
barrowman

Why can't I animate something to 0 and then reanimate it?

Recommended Posts

This is driving me mad, I have a simple Timeline, that works pretty well, except for some reason after I fade a MC out, I want to fade it back in later in animation/timeline and it just won't animate, instead it just appears/jumps back straight to 100%. I'm lost on why it wont or how to fix it. (or what even to search for in terms of reanimating the same thing later in the TL/

 

var til = new TimelineLite();
//
til.to(this.WB01, 1.00, {alpha:0, ease: Sine.easeInOut, overwrite: false}, 1.5)
.to(this.Logo, 1.00, {alpha:0, ease: Sine.easeInOut, overwrite: false}, 2)
.to(this.WB02, 1.00, {alpha:0, ease: Sine.easeInOut, overwrite: false}, 2)
.to(this.WB03, 1.00, {alpha:0, ease: Sine.easeInOut, overwrite: false}, 2.8)
.from(this.Logo_Final, 1.00, {alpha:0, ease: Sine.easeInOut, overwrite: false}, 6)
.to(this.WB02, 1.00, {alpha:100, ease: Sine.easeInOut, overwrite: false}, 6) // - this is the  line
.from(this.CTA, 1.00, {alpha:0, ease: Sine.easeInOut, overwrite: false}, "-=0.5")

 

Any help or a push in the right direction would be much appreciated.

Link to post
Share on other sites

Your code seems fine. No tweens overwriting the previous ones. Strange.

What happens when you animate other properties, like size or rotation instead of alpha?
 

Link to post
Share on other sites

It's probably because you're animating to alpha:100 instead of alpha:1. :)

  • Like 6
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×