Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Smedi

No entrys in console - morphSVG - precompile and shapeIndex: 'log'

Recommended Posts

I have a little animation with the morphSVG plugin and would use the precompiled calculations for performance optimizing. So i use precompile: "log", but in the console is nothing to see. Same on shapeIndex: "log". I was wondering why - it seems correct to me.

See the Pen eWgrEp by Smedia (@Smedia) on CodePen

Share this post


Link to post
Share on other sites

Ah, that's because you're not using <path> elements. Those are much more flexible. The easy fix would be to convert your <polyline>/<polygon> elements to <path> elements which is super easy with:

MorphSVGPlugin.convertToPath("polygon, polyline");

Does that help? Sorry about any confusion there. I've added a note to the docs now. 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×