Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Surge

_gsTransform undefined or just not accessing it correctly?

Go to solution Solved by Jonathan,

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi. Please can anyone help me get the transform.x of a node that is being animated by timelinemax?

 

Please see codepen for my attempts.

Thanks.

 

See the Pen amyzNJ by chrissowerby (@chrissowerby) on CodePen

Link to comment
Share on other sites

  • Solution

Hello Surge, and Welcome to the GreenSock Forum!

 

You have to get it like this when using jQuery

$('.test').get(0)._gsTransform.x; // like this
$('.test')[0]._gsTransform.x; // or like this

Happy Tweening :)

  • Like 3
Link to comment
Share on other sites

Thanks Jonathan. 

 

That fixed it! 
 

var transform_x = $(".test")[0]._gsTransform.xPercent;
  • Like 1
Link to comment
Share on other sites

Glad you got it working Surge :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×