Jump to content


SVG animation with GSAP - Graphical Trailing Glitch

Moderator Tag
Go to solution Solved by PointC,

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

I'm currently using GSAP to create a few banners with SVG shapes (text from Illustrator outline since I can't get Webfonts for these). They work and look fine on my machine, but when tested on a PC in Chrome, there is a small issue where the moving SVG element leaves a sort of "trail" graphically, but only when viewed at 100%.

I've attached a mocked up version of the issue (I tried getting the user to provide a zoomed in screenshot but she says the issue vanished when zoomed in).

Has anyone encountered this when animating SVG elements? I am imagining it is probably a hardware issue.



Link to comment
Share on other sites

Hi bandaro, do you think you could setup a reduced example where the issue is reproduced? I've never heard or seen such behaviour. We'll be more than happy to assist you but we will need to able to see the issue in question.



Link to comment
Share on other sites

  • Solution

GSAP only animates numeric properties. It doesn't do any of the rendering so I don't see how this could be caused by the platform. 


It sure looks like a graphics card/driver problem to me.


Happy tweening.


Link to comment
Share on other sites

I agree with @PointC.


I've had similar issues when animating SVG's on older versions of iOS, and although that was using SMIL rather than GSAP, but I doubt that would have made a huge difference.


I would test on other PC machine with the same version of Windows/Chrome.


One question though, is that text an SVG font? or has the text been converted to outlines? 

Link to comment
Share on other sites

Text was converted to outlines. I'm assuming it is a hardware issue, as mentioned here. I haven't gotten the chance to test on an alt machine yet, but I'll do that. Thanks!

Link to comment
Share on other sites

  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.