Jump to content


Cannot get new motionBlur working =( [SOLVED]

Recommended Posts



I can't get the motionBlur to work whatever I try... I've downloaded the new com folder for v11 and i'm using the code below:


import com.greensock.TweenMax;
import com.greensock.plugins.TweenPlugin;
TweenPlugin.activate([MotionBlurPlugin]); //only do this once in your SWF to activate the plugin
TweenMax.to(ball_mc, 2, {_x:400, _y:300, motionBlur:true});


Am I missing something here? Do I need to donate to get the MotionBlurPlugin.as file? I also attached all my source [attachment=0]motionblurTest.zip[/attachment] including the new com folder... I appreciate it very much :)

Link to comment
Share on other sites

Looks like you forgot to import the MotionBlurPlugin itself :) This will import 'em all:


import com.greensock.plugins.*;

Link to comment
Share on other sites

this produces an error:


The class 'com.greensock.plugins.TweenPlugin' cannot be imported because its leaf name is already being resolved to imported class 'com.greensock.plugins.TweenPlugin'.
Link to comment
Share on other sites

Something funky is going on - please post a simple FLA that demonstrates the issue. I'm confident we can get this working, but I'm working blind here. Seems to work great for everyone else (me included), so we've gotta figure out what's different about your system, your import statements, or something. Did you maybe forget to remove the import com.greensock.plugins.TweenPlugin statement when you added import com.greensock.plugins.*?

Link to comment
Share on other sites

Once I added the actual MotionBlurPlugin file (it wasn't included in your zip) and republished, it worked fine for me. I was using the latest v11 release. Maybe download the code again, clear your ASO files and republish?

Link to comment
Share on other sites

MotionBlurPlugin is a members-only bonus class for Club GreenSock members - that's why it's not in the downloads at http://blog.greensock.com/v11beta/. I just sent you an e-mail with the plugin.


I guess that'd explain why it wasn't working for you - you didn't have the plugin :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.