Jump to content
GreenSock

fripi

change a text during timeline doesn't work

Go to solution Solved by ohem,

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi,

I'm working on a banner and it would be nice to update a textfield in it

I used the TextPlugin with a simple syntax:

.set(cta, {text:"Découvrez granini<br>orange"})

But it doesn't work, so I tried in codepen and there it works!

 

So that's why I'm not linking a codepen in this post, because I can make it work on codepen, but not in my local file, can someone look at the html attached and check if you see something, I'm turning nuts here and just can't see why it work on codepen and not in my banner.

 

Thank you

granini_breakfast_300x600_FR.zip

Link to comment
Share on other sites

  • Solution

If you update the Greensock CDN links to the 1.18.2 versions, that fixes it:

<script src="https://cdnjs.cloudflare.com/ajax/libs/gsap/1.18.2/TweenMax.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/gsap/1.18.2/plugins/TextPlugin.min.js"></script>

The "latest" CDN links are often not actually up to date, so something about those versions was causing the issue.

  • Like 3
Link to comment
Share on other sites

omg... that's really THE thing I hadn't tested, thanks a lot!

so I wasn't completelly wrong in my code, even if it's not fantastic :-D

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×