Jump to content

Search In
  • More options...
Find results that contain...
Find results in...

Google Web Designer, GSAP not loading on page

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts


I'm making an html page with GWD with an animated header using GSAP. When I run my Preview on GWD everything loads fine. But when I upload to the server, the animation jumps to the final frame or sometimes executes part of the animation.


When uploading to the server tried both Inline and not Inline the local files (.js, .css) on the html.

And loading the GSAP from the cloud 

<script src="http://cdnjs.cloudflare.com/ajax/libs/gsap/1.16.0/TweenMax.min.js"></script>


I'm a flash developer, not an expert on HMTL. Would like to learn GWD for banners ads and eventually for my own html files, trying some tools of the GS club but I'm not sure how compatible is GSAP with GWD. *I loved to use GSAP in my Flash banners.


Any thoughts will be greatly appreciated. Thank you!








See the Pen XJOydd by Lujan30 (@Lujan30) on CodePen

Link to comment
Share on other sites

First of all, welcome! Lots of Flash developers find themselves in a similar spot, making their way into the HTML5 world. Don't worry - you're gonna love it once you get comfortable.


And yes, GSAP is pretty much compatible with anything as far as I know. It's just JavaScript. Unlike some other frameworks, it doesn't force you to build your stuff in a very specific way - it just sits on the JavaScript layer and you issue commands to animate properties of whatever you want, and it jumps into action. I cannot imagine how GWD could be incompatible unless GWD itself is doing something really funky, but I highly doubt that.


It's pretty tough to diagnose blind, so would you be able to zip a set of files and upload them or create a sample codepen or something? It'd be super helpful in trying to help you. Even if you just want to link us to the broken URL where things are jumping to the end or whatever. We'd love to help, but we need a little more to go on :)

  • Like 2
Link to comment
Share on other sites

Hi Jack,

Thank you so much for your response!

I'm attaching 2 GWD zip files along with the screen shots on how this was published. 

These are the urls that the animations are not working:


Ad environment ( Zip file attached: GoatSheepRam-Ad)



Standard HTML (Zip file: Html-page)



And just in case I'm adding an animation made with only GWD



I noticed GWD generates a lot of coding which I wasn't able to translate into the CodePen. I made a very basic one of what I want to achieve on my banner, it is very simple (almost embarrassing  :? ) here: 

See the Pen XJOydd by Lujan30 (@Lujan30) on CodePen


Overall I would like to know what I'm doing wrong in GWD working with GSAP since I can't see my animation on the server (only on the Preview).


Thanks a lot!





Link to comment
Share on other sites

Hi again,

Sorry but tried to attach the second file corresponding to this case :

Standard HTML (Zip file: Html-page)

http://10raven.com/goatsheepram/page/ but the file is too big.


I wait until you guys can take a look to my first post and I go from there. Thanks a lot!



Link to comment
Share on other sites

Hi Lujan30  :)


in your Standard HTML you have syntax error : you need " } " at the end of your code , before the </script> to close window.onload function .

Link to comment
Share on other sites

Hi Diaco.AW

Oooh! THANK YOU! ! Yes! 


Now I'm not sure about the Google Ad why is not working. I then suspect that this is only going to show if I upload to their Doubleclick studio server?


Thanks a lot for the help, already feeling excited making my way into HTML5 :)



Link to comment
Share on other sites

Good find, Diaco. 


Lujan30, did you still need help with something? I just want to make sure you're all set. You were going to try to upload the ad to their server and verify that it works, right? 

  • Like 1
Link to comment
Share on other sites

Hi Jack!

Correct, will upload the file on their server shortly to verify that it works. 

Thanks a lot for your help !



Link to comment
Share on other sites

  • 1 month later...

Hello Lujan,


Im having the same trouble here. But it is not related to a syntax error. It just loads only when all elements are finished loading. Did you find the solution?


Regards Hans

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.